Debian 9820 Published by

A libfastjson security update has been released for Debian GNU/Linux 10 LTS to address an issue that result in an out-of-bounds write.



[SECURITY] [DLA 3461-1] libfastjson security update


- -------------------------------------------------------------------------
Debian LTS Advisory DLA-3461-1 debian-lts@lists.debian.org
https://www.debian.org/lts/security/ Thorsten Alteholz
June 20, 2023 https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package : libfastjson
Version : 0.99.8-2+deb10u1
CVE ID : CVE-2020-12762

An issue has been found in libfastjson, a fast json library for C.
Due to missing checks, out-of-bounds write might happen when parsing
large JSON files.

For Debian 10 buster, this problem has been fixed in version
0.99.8-2+deb10u1.

We recommend that you upgrade your libfastjson packages.

For the detailed security status of libfastjson please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/libfastjson

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS