Ubuntu 6415 Published by

A Ghostscript security update has been released for Ubuntu Linux 16.04 LTS, 18.04 LTS, 20.04 LTS, 22.04 LTS, and 23.04.



[USN-6297-1] Ghostscript vulnerability


==========================================================================
Ubuntu Security Notice USN-6297-1
August 17, 2023

ghostscript vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 23.04
- Ubuntu 22.04 LTS
- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS (Available with Ubuntu Pro)
- Ubuntu 16.04 LTS (Available with Ubuntu Pro)

Summary:

Ghostscript could be made to crash if it received specially crafted input.

Software Description:
- ghostscript: PostScript and PDF interpreter

Details:

It was discovered that Ghostscript incorrectly handled outputting certain
PDF files. A local attacker could potentially use this issue to cause
a crash, resulting in a denial of service.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 23.04:
  ghostscript                     10.0.0~dfsg1-0ubuntu1.3
  libgs10                         10.0.0~dfsg1-0ubuntu1.3

Ubuntu 22.04 LTS:
  ghostscript                     9.55.0~dfsg1-0ubuntu5.4
  libgs9                          9.55.0~dfsg1-0ubuntu5.4

Ubuntu 20.04 LTS:
  ghostscript                     9.50~dfsg-5ubuntu4.9
  libgs9                          9.50~dfsg-5ubuntu4.9

Ubuntu 18.04 LTS (Available with Ubuntu Pro):
  ghostscript 9.26~dfsg+0-0ubuntu0.18.04.18+esm1
  libgs9 9.26~dfsg+0-0ubuntu0.18.04.18+esm1

Ubuntu 16.04 LTS (Available with Ubuntu Pro):
  ghostscript 9.26~dfsg+0-0ubuntu0.16.04.14+esm6
  libgs9 9.26~dfsg+0-0ubuntu0.16.04.14+esm6

In general, a standard system update will make all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-6297-1
  CVE-2023-38559

Package Information:
https://launchpad.net/ubuntu/+source/ghostscript/10.0.0~dfsg1-0ubuntu1.3
https://launchpad.net/ubuntu/+source/ghostscript/9.55.0~dfsg1-0ubuntu5.4
https://launchpad.net/ubuntu/+source/ghostscript/9.50~dfsg-5ubuntu4.9