SUSE 5054 Published by

A perl-Cpanel-JSON-XS security update has been released for SUSE Linux Enterprise 15 SP5.



openSUSE-SU-2023:0225-1: moderate: Security update for perl-Cpanel-JSON-XS


openSUSE Security Update: Security update for perl-Cpanel-JSON-XS
_______________________________

Announcement ID: openSUSE-SU-2023:0225-1
Rating: moderate
References:
Affected Products:
openSUSE Backports SLE-15-SP5
_______________________________

An update that contains security fixes can now be installed.

Description:

This update for perl-Cpanel-JSON-XS fixes the following issues:

perl-Cpanel-JSON-XS was updated to 4.36

see /usr/share/doc/packages/perl-Cpanel-JSON-XS/Changes

* 4.36 2023-03-02 (rurban)

- remove the SAVESTACK_POS noop. Merged from JSON-XS-3.02, removed
there with 4.0. requested to remove with
L ( https://github.com/Perl/perl5/pull/20858)

* 4.35 2023-02-22 (rurban)

- fix utf8 object stringification (jixam PR #212)

* 4.34 2023-02-21 (rurban)

- fix c89 compilation regression, for loop init on centos. GH #211

* 4.33 2023-02-21 (rurban)

- fix a security issue, decoding hash keys without ending : (GH #208)
- check all bare hash keys for utf8 (GH #209)
- improve overload warnings (Graham Knop PR #205)
- fix a croak leak (GH #206)

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Backports SLE-15-SP5:

zypper in -t patch openSUSE-2023-225=1

Package List:

- openSUSE Backports SLE-15-SP5 (aarch64 i586 ppc64le s390x x86_64):

perl-Cpanel-JSON-XS-4.36-bp155.2.3.1

References: