Ubuntu 6411 Published by

A Kamailio security update has been released for Ubuntu Linux 16.04 ESM, 18.04 ESM, and 20.04 ESM.



USN-6022-1: Kamailio vulnerabilities


=========================================================================
Ubuntu Security Notice USN-6022-1
April 14, 2023

kamailio vulnerabilities
=========================================================================
A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 20.04 ESM
- Ubuntu 18.04 ESM
- Ubuntu 16.04 ESM

Summary:

Kamailio could be made to crash or run programs if it received specially
crafted input.

Software Description:
- kamailio: very fast, dynamic and configurable SIP server

Details:

It was discovered that Kamailio did not properly sanitize SIP messages under
certain circumstances. An attacker could use this vulnerability to cause a
denial of service or possibly execute arbitrary code. This issue only affected
Ubuntu 16.04 ESM and 18.04 ESM. (CVE-2018-16657)

It was discovered that Kamailio did not properly validate INVITE requests
under certain circumstances. An attacker could use this vulnerability to
cause a denial of service or possibly execute arbitrary code. (CVE-2020-27507)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 20.04 ESM:
kamailio 5.3.2-1ubuntu0.1~esm1

Ubuntu 18.04 ESM:
kamailio 5.1.2-1ubuntu2+esm1

Ubuntu 16.04 ESM:
kamailio 4.3.4-1.1ubuntu2.1+esm1

In general, a standard system update will make all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-6022-1
CVE-2018-16657, CVE-2020-27507

--wa6y27qhoglwc27b