Debian 9982 Published by

A ruby-rack security update has been released for Debian GNU/Linux 10 LTS to address two ruby-rack issues.



DLA 3392-1: ruby-rack security update



- -------------------------------------------------------------------------
Debian LTS Advisory DLA-3392-1 debian-lts@lists.debian.org
  https://www.debian.org/lts/security/ Scarlett Moore
April 17, 2023   https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package : ruby-rack
Version : 2.0.6-3+deb10u3
CVE ID : CVE-2023-27530 CVE-2023-27539
Debian Bug :

Two ruby-rack issues have been addressed:

CVE-2023-27530

Description: Limit all multipart parts, not just files.

CVE-2023-27539

Description: Split headers on commas, then strip the strings in
order to avoid ReDoS issues.

For Debian 10 buster, these problems have been fixed in version
2.0.6-3+deb10u3.

We recommend that you upgrade your ruby-rack packages.

For the detailed security status of ruby-rack please refer to
its security tracker page at:
  https://security-tracker.debian.org/tracker/ruby-rack

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at:   https://wiki.debian.org/LTS