Ubuntu 6283 Published by

A Pygments security update has been released for Ubuntu 14.04 LTS.



[USN-4897-2] Pygments vulnerabilities


==========================================================================
Ubuntu Security Notice USN-4897-2
August 14, 2023

pygments vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 14.04 LTS (Available with Ubuntu Pro)

Summary:

Pygments could be made to hang if it opened a specially crafted file.

Software Description:
- pygments: Generic syntax highlighter

Details:

USN-4897-1 fixed several vulnerabilities in Pygments. This update provides
the corresponding update for Ubuntu 14.04 LTS.

Original advisory details:

Ben Caller discovered that Pygments incorrectly handled parsing certain
files. If a user or automated system were tricked into parsing a specially
crafted file, a remote attacker could cause Pygments to hang or consume
resources, resulting in a denial of service. (CVE-2021-27291)

It was discovered that Pygments incorrectly handled parsing certain
files. An attacker could possibly use this issue to cause a denial of
service. (CVE-2021-20270)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 14.04 LTS (Available with Ubuntu Pro):
python-pygments 1.6+dfsg-1ubuntu1.1+esm1
python3-pygments 1.6+dfsg-1ubuntu1.1+esm1

In general, a standard system update will make all the necessary changes.

References:
https://ubuntu.com/security/notices/USN-4897-2
https://ubuntu.com/security/notices/USN-4897-1
CVE-2021-20270, CVE-2021-27291