SUSE 4999 Published by

A qatengine security update has been released for openSUSE Leap 15.4 and SUSE Linux Enterprise.



SUSE-SU-2023:3290-1: moderate: Security update for qatengine


# Security update for qatengine

Announcement ID: SUSE-SU-2023:3290-1
Rating: moderate
References:

* #1211296

Cross-References:

* CVE-2022-43507

CVSS scores:

* CVE-2022-43507 ( SUSE ): 6.4 CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:H
* CVE-2022-43507 ( NVD ): 7.5 CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Affected Products:

* Basesystem Module 15-SP4
* openSUSE Leap 15.4
* SUSE Linux Enterprise Desktop 15 SP4
* SUSE Linux Enterprise High Performance Computing 15 SP4
* SUSE Linux Enterprise Real Time 15 SP4
* SUSE Linux Enterprise Server 15 SP4
* SUSE Linux Enterprise Server for SAP Applications 15 SP4
* SUSE Manager Proxy 4.3
* SUSE Manager Retail Branch Server 4.3
* SUSE Manager Server 4.3

An update that solves one vulnerability can now be installed.

## Description:

This update for qatengine fixes the following issues:

* CVE-2022-43507: Fixed a buffer overflow issue with SHA3. (bsc#1211296)

## Patch Instructions:

To install this SUSE Moderate update use the SUSE recommended installation
methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

* openSUSE Leap 15.4
zypper in -t patch SUSE-2023-3290=1 openSUSE-SLE-15.4-2023-3290=1

* Basesystem Module 15-SP4
zypper in -t patch SUSE-SLE-Module-Basesystem-15-SP4-2023-3290=1

## Package List:

* openSUSE Leap 15.4 (x86_64)
* qatengine-debugsource-0.6.10-150400.3.3.1
* qatengine-0.6.10-150400.3.3.1
* qatengine-debuginfo-0.6.10-150400.3.3.1
* Basesystem Module 15-SP4 (x86_64)
* qatengine-debugsource-0.6.10-150400.3.3.1
* qatengine-0.6.10-150400.3.3.1
* qatengine-debuginfo-0.6.10-150400.3.3.1

## References:

* https://www.suse.com/security/cve/CVE-2022-43507.html
* https://bugzilla.suse.com/show_bug.cgi?id=1211296