Oracle Linux 6203 Published by

A dotnet7.0 security, bug fix, and enhancement update has been released for Oracle Linux 9.



El-errata: ELSA-2022-8434 Moderate: Oracle Linux 9 dotnet7.0 security, bug fix, and enhancement update


Oracle Linux Security Advisory ELSA-2022-8434

  http://linux.oracle.com/errata/ELSA-2022-8434.html

The following updated rpms for Oracle Linux 9 have been uploaded to the Unbreakable Linux Network:

x86_64:
aspnetcore-runtime-7.0-7.0.0-0.5.rc2.0.1.el9_1.x86_64.rpm
aspnetcore-targeting-pack-7.0-7.0.0-0.5.rc2.0.1.el9_1.x86_64.rpm
dotnet-apphost-pack-7.0-7.0.0-0.5.rc2.0.1.el9_1.x86_64.rpm
dotnet-host-7.0.0-0.5.rc2.0.1.el9_1.x86_64.rpm
dotnet-hostfxr-7.0-7.0.0-0.5.rc2.0.1.el9_1.x86_64.rpm
dotnet-runtime-7.0-7.0.0-0.5.rc2.0.1.el9_1.x86_64.rpm
dotnet-sdk-7.0-7.0.100-0.5.rc2.0.1.el9_1.x86_64.rpm
dotnet-targeting-pack-7.0-7.0.0-0.5.rc2.0.1.el9_1.x86_64.rpm
dotnet-templates-7.0-7.0.100-0.5.rc2.0.1.el9_1.x86_64.rpm
netstandard-targeting-pack-2.1-7.0.100-0.5.rc2.0.1.el9_1.x86_64.rpm
dotnet-sdk-7.0-source-built-artifacts-7.0.100-0.5.rc2.0.1.el9_1.x86_64.rpm

aarch64:
aspnetcore-runtime-7.0-7.0.0-0.5.rc2.0.1.el9_1.aarch64.rpm
aspnetcore-targeting-pack-7.0-7.0.0-0.5.rc2.0.1.el9_1.aarch64.rpm
dotnet-apphost-pack-7.0-7.0.0-0.5.rc2.0.1.el9_1.aarch64.rpm
dotnet-host-7.0.0-0.5.rc2.0.1.el9_1.aarch64.rpm
dotnet-hostfxr-7.0-7.0.0-0.5.rc2.0.1.el9_1.aarch64.rpm
dotnet-runtime-7.0-7.0.0-0.5.rc2.0.1.el9_1.aarch64.rpm
dotnet-sdk-7.0-7.0.100-0.5.rc2.0.1.el9_1.aarch64.rpm
dotnet-targeting-pack-7.0-7.0.0-0.5.rc2.0.1.el9_1.aarch64.rpm
dotnet-templates-7.0-7.0.100-0.5.rc2.0.1.el9_1.aarch64.rpm
netstandard-targeting-pack-2.1-7.0.100-0.5.rc2.0.1.el9_1.aarch64.rpm
dotnet-sdk-7.0-source-built-artifacts-7.0.100-0.5.rc2.0.1.el9_1.aarch64.rpm

SRPMS:
  http://oss.oracle.com/ol9/SRPMS-updates/dotnet7.0-7.0.100-0.5.rc2.0.1.el9_1.src.rpm

Related CVEs:

CVE-2022-41032



Description of changes:

[7.0.100-0.5.rc2.0.1]
- Set TargetRid based on os release major version, add OL arm64 RuntimeIdentifier [Orabug: 34671152]

[7.0.100-0.5.rc2]
- Add lldb as a build dependency
- Related: RHBZ#2134641

[7.0.100-0.4.rc2]
- Enable ppc64le builds
- Related: RHBZ#2134641

[7.0.100-0.3.rc2]
- Update to .NET 7 RC 2
- Resolves: RHBZ#2134641

_______________________________________________