Oracle Linux 6138 Published by

A krb5 bug fix update has been released for Oracle Linux 9.



ELBA-2023-3731 Oracle Linux 9 krb5 bug fix update


Oracle Linux Bug Fix Advisory ELBA-2023-3731

http://linux.oracle.com/errata/ELBA-2023-3731.html

The following updated rpms for Oracle Linux 9 have been uploaded to the Unbreakable Linux Network:

x86_64:
krb5-devel-1.20.1-9.0.1.el9_2.i686.rpm
krb5-devel-1.20.1-9.0.1.el9_2.x86_64.rpm
krb5-libs-1.20.1-9.0.1.el9_2.i686.rpm
krb5-libs-1.20.1-9.0.1.el9_2.x86_64.rpm
krb5-pkinit-1.20.1-9.0.1.el9_2.i686.rpm
krb5-pkinit-1.20.1-9.0.1.el9_2.x86_64.rpm
krb5-server-1.20.1-9.0.1.el9_2.i686.rpm
krb5-server-1.20.1-9.0.1.el9_2.x86_64.rpm
krb5-server-ldap-1.20.1-9.0.1.el9_2.i686.rpm
krb5-server-ldap-1.20.1-9.0.1.el9_2.x86_64.rpm
krb5-workstation-1.20.1-9.0.1.el9_2.x86_64.rpm
libkadm5-1.20.1-9.0.1.el9_2.i686.rpm
libkadm5-1.20.1-9.0.1.el9_2.x86_64.rpm

aarch64:
krb5-devel-1.20.1-9.0.1.el9_2.aarch64.rpm
krb5-libs-1.20.1-9.0.1.el9_2.aarch64.rpm
krb5-pkinit-1.20.1-9.0.1.el9_2.aarch64.rpm
krb5-server-1.20.1-9.0.1.el9_2.aarch64.rpm
krb5-server-ldap-1.20.1-9.0.1.el9_2.aarch64.rpm
krb5-workstation-1.20.1-9.0.1.el9_2.aarch64.rpm
libkadm5-1.20.1-9.0.1.el9_2.aarch64.rpm

SRPMS:
http://oss.oracle.com/ol9/SRPMS-updates//krb5-1.20.1-9.0.1.el9_2.src.rpm

Description of changes:

[1.20.1-9.0.1]
- Fixed race condition in krb5_set_password() [Orabug: 33609767]

[1.20.1-9]
- Do not disable PKINIT if some of the well-known DH groups are unavailable
- Resolves: rhbz#2209715
- Make PKINIT CMS SHA-1 signature verification available in FIPS mode
- Resolves: rhbz#2209717
- Allow to set PAC ticket signature as optional
- Resolves: rhbz#2211388