Ubuntu 6283 Published by

An Intel Microcode security update has been released for Ubuntu Linux 16.04 LTS, 18.04 LTS, 20.04 LTS, 22.04 LTS, and 23.04.



[USN-6286-1] Intel Microcode vulnerabilities


==========================================================================
Ubuntu Security Notice USN-6286-1
August 14, 2023

intel-microcode vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 23.04
- Ubuntu 22.04 LTS
- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS (Available with Ubuntu Pro)
- Ubuntu 16.04 LTS (Available with Ubuntu Pro)

Summary:

Several security issues were fixed in Intel Microcode.

Software Description:
- intel-microcode: Processor microcode for Intel CPUs

Details:

Daniel Moghimi discovered that some Intel(R) Processors did not properly clear
microarchitectural state after speculative execution of various instructions. A
local unprivileged user could use this to obtain to sensitive
information. (CVE-2022-40982)

It was discovered that some Intel(R) Xeon(R) Processors did not properly
restrict error injection for Intel(R) SGX or Intel(R) TDX. A local privileged
user could use this to further escalate their privileges. (CVE-2022-41804)

It was discovered that some 3rd Generation Intel(R) Xeon(R) Scalable processors
did not properly restrict access in some situations. A local privileged attacker
could use this to obtain sensitive information. (CVE-2023-23908)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 23.04:
intel-microcode 3.20230808.0ubuntu1

Ubuntu 22.04 LTS:
intel-microcode 3.20230808.0ubuntu0.22.04.1

Ubuntu 20.04 LTS:
intel-microcode 3.20230808.0ubuntu0.20.04.1

Ubuntu 18.04 LTS (Available with Ubuntu Pro):
intel-microcode 3.20230808.0ubuntu0.18.04.1+esm1

Ubuntu 16.04 LTS (Available with Ubuntu Pro):
intel-microcode 3.20230808.0ubuntu0.16.04.1+esm1

After a standard system update you need to reboot your computer to make
all the necessary changes.

References:
https://ubuntu.com/security/notices/USN-6286-1
CVE-2022-40982, CVE-2022-41804, CVE-2023-23908

Package Information:
https://launchpad.net/ubuntu/+source/intel-microcode/3.20230808.0ubuntu1
https://launchpad.net/ubuntu/+source/intel-microcode/3.20230808.0ubuntu0.22.04.1
https://launchpad.net/ubuntu/+source/intel-microcode/3.20230808.0ubuntu0.20.04.1