Debian 10020 Published by

A netatalk regression update has been released for Debian GNU/Linux 10 LTS to address another regression introduced with the patch for CVE-2022-23123.



[SECURITY] [DLA 3426-3] netatalk regression update


-------------------------------------------------------------------------
Debian LTS Advisory DLA-3426-3 debian-lts@lists.debian.org
https://www.debian.org/lts/security/ Markus Koschany
August 13, 2023 https://wiki.debian.org/LTS
-------------------------------------------------------------------------

Package : netatalk
Version : 3.1.12~ds-3+deb10u3
CVE ID : CVE-2022-23123
Debian Bug : 1043504

Another regression was identified in Netatalk, the Apple Filing Protocol
service, introduced with the patch for CVE-2022-23123. It is impacting a
subset of users that have certain metadata in their shared files. The issue
leads to an unavoidable crash and renders netatalk useless with their shared
volumes.

Separately, it also contains a fix for saving MS Office files onto an
otherwise functioning shared volume.

For Debian 10 buster, this problem has been fixed in version
3.1.12~ds-3+deb10u3.

We recommend that you upgrade your netatalk packages.

For the detailed security status of netatalk please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/netatalk

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS