Ubuntu 6287 Published by

A libvirt security update has been released for Ubuntu Linux 23.04.



[USN-6253-1] libvirt vulnerability


==========================================================================
Ubuntu Security Notice USN-6253-1
July 26, 2023

libvirt vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 23.04

Summary:

libvirt could be made to stop responding or crash if it received specially
crafted commands.

Software Description:
- libvirt: Libvirt virtualization toolkit

Details:

It wad discovered that libvirt incorrectly handled locking when processing
certain requests. A local attacker could possibly use this issue to cause
libvirt to stop responding or crash, resulting in a denial of service.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 23.04:
libvirt-daemon 9.0.0-2ubuntu1.2
libvirt-daemon-system 9.0.0-2ubuntu1.2
libvirt0 9.0.0-2ubuntu1.2

After a standard system update you need to reboot your computer to make all
the necessary changes.

References:
https://ubuntu.com/security/notices/USN-6253-1
CVE-2023-3750

Package Information:
https://launchpad.net/ubuntu/+source/libvirt/9.0.0-2ubuntu1.2