Debian 9819 Published by

A curl security update has been released for Debian GNU/Linux 12 to address an incorrect file path handling, which could lead to the creation or overwriting of files.
of files.



[SECURITY] [DSA 5460-1] curl security update


- -------------------------------------------------------------------------
Debian Security Advisory DSA-5460-1 security@debian.org
https://www.debian.org/security/ Moritz Muehlenhoff
July 26, 2023 https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : curl
CVE ID : CVE-2023-32001

It was discovered that Curl performed incorrect file path handling when
saving cookies to files, which could lead to the creation or overwriting
of files.

The oldstable distribution (bullseye) is not affected.

For the stable distribution (bookworm), this problem has been fixed in
version 7.88.1-10+deb12u1.

We recommend that you upgrade your curl packages.

For the detailed security status of curl please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/curl

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/