Ubuntu 6283 Published by

A lib3mf security update has been released for Ubuntu Linux 20.04 LTS.



[USN-6216-1] lib3mf vulnerability


==========================================================================
Ubuntu Security Notice USN-6216-1
July 11, 2023

lib3mf vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 20.04 LTS

Summary:

lib3mf could be made to execute arbitrary code if it opens a specially
crafted 3MF file.

Software Description:
- lib3mf: Lib3MF is a C++ implementation of the 3D Manufacturing Format

Details:

It was discovered that lib3mf did not properly manage memory under
certain circumstances. If a user were tricked into opening a specially
crafted 3MF file, a local attacker could possibly use this issue to
cause applications using lib3mf to crash, resulting in a denial of
service, or possibly execute arbitrary code.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 20.04 LTS:
  lib3mf-dev                      1.8.1+ds-3ubuntu0.2
  lib3mf1                         1.8.1+ds-3ubuntu0.2

In general, a standard system update will make all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-6216-1
  CVE-2021-21772

Package Information:
  https://launchpad.net/ubuntu/+source/lib3mf/1.8.1+ds-3ubuntu0.2