Ubuntu 6283 Published by

A Knot Resolver security update has been released for Ubuntu Linux 16.04 LTS, 18.04 LTS, 20.04 LTS, 22.04 LTS, and 22.10.



[USN-6225-1] Knot Resolver vulnerability


==========================================================================
Ubuntu Security Notice USN-6225-1
July 13, 2023

knot-resolver vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 22.10
- Ubuntu 22.04 LTS (Available with Ubuntu Pro)
- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS (Available with Ubuntu Pro)
- Ubuntu 16.04 LTS (Available with Ubuntu Pro)

Summary:

Knot Resolver could be made to crash if it received specially crafted
network traffic.

Software Description:
- knot-resolver: caching, DNSSEC-validating DNS resolver

Details:

It was discovered that Knot Resolver did not correctly handle certain
client options. A remote attacker could send requests to malicous domains
and cause a denial of service.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 22.10:
knot-resolver 5.5.1-5ubuntu0.22.10.1

Ubuntu 22.04 LTS (Available with Ubuntu Pro):
knot-resolver 5.4.4-1ubuntu0.1~esm1

Ubuntu 20.04 LTS:
knot-resolver 3.2.1-3ubuntu2.1

Ubuntu 18.04 LTS (Available with Ubuntu Pro):
knot-resolver 2.1.1-1ubuntu0.1~esm2
libkres-dev 2.1.1-1ubuntu0.1~esm2
libkres6 2.1.1-1ubuntu0.1~esm2

Ubuntu 16.04 LTS (Available with Ubuntu Pro):
knot-resolver 1.0.0~beta3-1ubuntu0.1~esm1

In general, a standard system update will make all the necessary changes.

References:
https://ubuntu.com/security/notices/USN-6225-1
CVE-2022-40188

Package Information:
https://launchpad.net/ubuntu/+source/knot-resolver/5.5.1-5ubuntu0.22.10.1
https://launchpad.net/ubuntu/+source/knot-resolver/3.2.1-3ubuntu2.1