Ubuntu 6287 Published by

An AccountsService security update has been released for Ubuntu Linux 20.04 LTS, 22.04 LTS, 22.10, and 23.04.



[USN-6190-1] AccountsService vulnerability


==========================================================================
Ubuntu Security Notice USN-6190-1
June 28, 2023

accountsservice vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 23.04
- Ubuntu 22.10
- Ubuntu 22.04 LTS
- Ubuntu 20.04 LTS

Summary:

AccountsService could be made to crash or run programs if it received
specially crafted messages.

Software Description:
- accountsservice: query and manipulate user account information

Details:

Kevin Backhouse discovered that AccountsService incorrectly handled certain
D-Bus messages. A local attacker could use this issue to cause
AccountsService to crash, resulting in a denial of service, or possibly
execute arbitrary code.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 23.04:
accountsservice 22.08.8-1ubuntu7.1
libaccountsservice0 22.08.8-1ubuntu7.1

Ubuntu 22.10:
accountsservice 22.08.8-1ubuntu1.1
libaccountsservice0 22.08.8-1ubuntu1.1

Ubuntu 22.04 LTS:
accountsservice 22.07.5-2ubuntu1.4
libaccountsservice0 22.07.5-2ubuntu1.4

Ubuntu 20.04 LTS:
accountsservice 0.6.55-0ubuntu12~20.04.6
libaccountsservice0 0.6.55-0ubuntu12~20.04.6

After a standard system update you need to reboot your computer to make all
the necessary changes.

References:
https://ubuntu.com/security/notices/USN-6190-1
CVE-2023-3297

Package Information:
https://launchpad.net/ubuntu/+source/accountsservice/22.08.8-1ubuntu7.1
https://launchpad.net/ubuntu/+source/accountsservice/22.08.8-1ubuntu1.1
https://launchpad.net/ubuntu/+source/accountsservice/22.07.5-2ubuntu1.4
https://launchpad.net/ubuntu/+source/accountsservice/0.6.55-0ubuntu12~20.04.6