Ubuntu 6290 Published by

A CUPS vulnerability has been released for Ubuntu Linux 20.04 LTS, 22.04 LTS, 22.10, and 23.04.





==========================================================================
Ubuntu Security Notice USN-6184-1
June 22, 2023

cups vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 23.04
- Ubuntu 22.10
- Ubuntu 22.04 LTS
- Ubuntu 20.04 LTS

Summary:

CUPS could be made to crash or expose sensitive information over the
network.

Software Description:
- cups: Common UNIX Printing System(tm)

Details:

It was discovered that CUPS incorrectly handled certain memory operations.
An attacker could possibly use this issue to cause CUPS to crash, resulting
in a denial of service, or possibly obtain sensitive information.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 23.04:
  cups                            2.4.2-3ubuntu2.2

Ubuntu 22.10:
  cups                            2.4.2-1ubuntu2.2

Ubuntu 22.04 LTS:
  cups                            2.4.1op1-1ubuntu4.4

Ubuntu 20.04 LTS:
  cups                            2.3.1-9ubuntu1.4

In general, a standard system update will make all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-6184-1
  CVE-2023-34241

Package Information:
  https://launchpad.net/ubuntu/+source/cups/2.4.2-3ubuntu2.2
  https://launchpad.net/ubuntu/+source/cups/2.4.2-1ubuntu2.2
  https://launchpad.net/ubuntu/+source/cups/2.4.1op1-1ubuntu4.4
  https://launchpad.net/ubuntu/+source/cups/2.3.1-9ubuntu1.4