Ubuntu 6289 Published by

A Ruby security update has been released for Ubuntu Linux 22.10 and 23.04.



[USN-6181-1] Ruby vulnerabilities


==========================================================================
Ubuntu Security Notice USN-6181-1
June 21, 2023

ruby3.1 vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 23.04
- Ubuntu 22.10

Summary:

Several security issues were fixed in Ruby.

Software Description:
- ruby3.1: Interpreter of object-oriented scripting language Ruby

Details:

Hiroshi Tokumaru discovered that Ruby did not properly handle certain
user input for applications the generate HTTP responses using cgi gem.
An attacker could possibly use this issue to maliciously modify the
response a user would receive from a vulnerable application. This issue
only affected Ubuntu 22.10. (CVE-2021-33621)

It was discovered that Ruby incorrectly handled certain regular expressions.
An attacker could possibly use this issue to cause a denial of service.
(CVE-2023-28755, CVE-2023-28756)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 23.04:
libruby3.1 3.1.2-6ubuntu0.23.04.1
ruby3.1 3.1.2-6ubuntu0.23.04.1

Ubuntu 22.10:
libruby3.1 3.1.2-2ubuntu0.22.10.1
ruby3.1 3.1.2-2ubuntu0.22.10.1

In general, a standard system update will make all the necessary changes.

References:
https://ubuntu.com/security/notices/USN-6181-1
CVE-2021-33621, CVE-2023-28755, CVE-2023-28756

Package Information:
https://launchpad.net/ubuntu/+source/ruby3.1/3.1.2-6ubuntu0.23.04.1
https://launchpad.net/ubuntu/+source/ruby3.1/3.1.2-2ubuntu0.22.10.1