Ubuntu 6289 Published by

A SVG++ library security update has been released for Ubuntu Linux 18.04 LTS, 22.04 LTS, and 22.10.



[USN-6178-1] SVG++ library vulnerabilities


==========================================================================
Ubuntu Security Notice USN-6178-1
June 19, 2023

Several security issues were fixed in SVG++ library
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 22.10
- Ubuntu 22.04 LTS
- Ubuntu 18.04 LTS (Available with Ubuntu Pro)

Details:

It was discovered that in SVG++ library that the demo application incorrectly
managed memory resulting in a memory access violation
under certain circumstances. An attacker could possibly use this issue
to leak memory information or run a denial of service attack.
This issue only affected Ubuntu 18.04 LTS. (CVE-2019-6246)

It was discovered that in SVG++ library that the demo application
incorrectly handled null pointers under certain circumstances.
An attacker could possibly use this issue to cause
denial of service, leak memory information or manipulate
program execution flow. (CVE-2021-44960)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 22.10:
libsvgpp-dev 1.3.0+dfsg1-3ubuntu2.22.10.1

Ubuntu 22.04 LTS:
libsvgpp-dev 1.3.0+dfsg1-3ubuntu2.22.04.1

Ubuntu 18.04 LTS (Available with Ubuntu Pro):
libsvgpp-dev 1.2.3+dfsg1-3ubuntu1+esm1

The problem can be corrected by updating your system to the following package versions:

References:
https://ubuntu.com/security/notices/USN-6178-1
CVE-2019-6246, CVE-2021-44960

Package Information:
https://launchpad.net/ubuntu/+source/svgpp/1.3.0+dfsg1-3ubuntu2.22.10.1
https://launchpad.net/ubuntu/+source/svgpp/1.3.0+dfsg1-3ubuntu2.22.04.1