Ubuntu 6347 Published by

A xfce4-settings security update has been released for Ubuntu Linux 22.10 and 22.04 LTS.



[USN-6141-1] xfce4-settings vulnerability


==========================================================================
Ubuntu Security Notice USN-6141-1
June 06, 2023

xfce4-settings vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 22.10
- Ubuntu 22.04 LTS

Summary:

xfce4-settings could be made to run programs with arbitrary arguments
if it received specially crafted input.

Software Description:
- xfce4-settings: graphical application for managing Xfce settings

Details:

Robin Peraglie and Johannes Moritz discovered that xfce4-settings
incorrectly parsed quoted input when processed through xdg-open.
A remote attacker could possibly use this issue to inject
arbitrary arguments into the default browser or file manager.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 22.10:
  xfce4-settings                  4.16.2-1ubuntu2.22.10.1

Ubuntu 22.04 LTS:
  xfce4-settings                  4.16.2-1ubuntu2.22.04.1

In general, a standard system update will make all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-6141-1
  CVE-2022-45062

Package Information:
https://launchpad.net/ubuntu/+source/xfce4-settings/4.16.2-1ubuntu2.22.10.1
https://launchpad.net/ubuntu/+source/xfce4-settings/4.16.2-1ubuntu2.22.04.1