Ubuntu 6037 Published by

An Apache Batik security update has been released for Ubuntu Linux 14.04 LTS, 16.04 LTS, 18.04 LTS, 20.04 LTS, 22.04 LTS, and 22.10.



[USN-6117-1] Apache Batik vulnerabilities


==========================================================================
Ubuntu Security Notice USN-6117-1
May 30, 2023

batik vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 22.10
- Ubuntu 22.04 LTS
- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS
- Ubuntu 16.04 LTS (Available with Ubuntu Pro)
- Ubuntu 14.04 LTS (Available with Ubuntu Pro)

Summary:

Several security issues were fixed in Apache Batik.

Software Description:
- batik: SVG Library

Details:

It was discovered that Apache Batik incorrectly handled certain inputs. An
attacker could possibly use this to perform a cross site request forgery
attack. (CVE-2019-17566, CVE-2020-11987, CVE-2022-38398, CVE-2022-38648)

It was discovered that Apache Batik incorrectly handled Jar URLs in some
situations. A remote attacker could use this issue to access files on the
server. (CVE-2022-40146)

It was discovered that Apache Batik allowed running untrusted Java code from
an SVG. An attacker could use this issue to cause a denial of service,
or possibly execute arbitrary code. (CVE-2022-41704, CVE-2022-42890)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 22.10:
libbatik-java 1.14-2ubuntu0.1

Ubuntu 22.04 LTS:
libbatik-java 1.14-1ubuntu0.2

Ubuntu 20.04 LTS:
libbatik-java 1.12-1ubuntu0.1

Ubuntu 18.04 LTS:
libbatik-java 1.10-2~18.04.1

Ubuntu 16.04 LTS (Available with Ubuntu Pro):
libbatik-java 1.8-3ubuntu1+esm1

Ubuntu 14.04 LTS (Available with Ubuntu Pro):
libbatik-java 1.7.ubuntu-8ubuntu2.14.04.3+esm1

In general, a standard system update will make all the necessary changes.

References:
https://ubuntu.com/security/notices/USN-6117-1
CVE-2019-17566, CVE-2020-11987, CVE-2022-38398, CVE-2022-38648,
CVE-2022-40146, CVE-2022-41704, CVE-2022-42890

Package Information:
https://launchpad.net/ubuntu/+source/batik/1.14-2ubuntu0.1
https://launchpad.net/ubuntu/+source/batik/1.14-1ubuntu0.2
https://launchpad.net/ubuntu/+source/batik/1.12-1ubuntu0.1
https://launchpad.net/ubuntu/+source/batik/1.10-2~18.04.1