Ubuntu 6411 Published by

A Sudo security update has been released for Ubuntu Linux 16.04 LTS.



[USN-6005-2] Sudo vulnerabilities


==========================================================================
Ubuntu Security Notice USN-6005-2
May 29, 2023

sudo vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 16.04 LTS (Available with Ubuntu Pro)

Summary:

Several security issues were fixed in Sudo.

Software Description:
- sudo: Provide limited super user privileges to specific users

Details:

USN-6005-1 fixed vulnerabilities in Sudo. This update
provides the corresponding updates for Ubuntu 16.04 LTS.

Original advisory details:

 Matthieu Barjole and Victor Cutillas discovered that Sudo incorrectly
 escaped control characters in log messages and sudoreplay output. An
 attacker could possibly use these issues to inject terminal control
 characters that alter output when being viewed.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 16.04 LTS (Available with Ubuntu Pro):
  sudo                               1.8.16-0ubuntu1.10+esm2
  sudo-ldap                       1.8.16-0ubuntu1.10+esm2

In general, a standard system update will make all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-6005-2
  https://ubuntu.com/security/notices/USN-6005-1
  CVE-2023-28486, CVE-2023-28487