Ubuntu 6283 Published by

A PHP security update has been released for Ubuntu Linux 18.04 LS, 20.04 LTS, 22.04 LTS, and 22.10.



USN-5902-1: PHP vulnerabilities


==========================================================================
Ubuntu Security Notice USN-5902-1
February 28, 2023

php7.2, php7.4, php8.1 vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 22.10
- Ubuntu 22.04 LTS
- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS

Summary:

Several security issues were fixed in PHP.

Software Description:
- php8.1: HTML-embedded scripting language interpreter
- php7.4: HTML-embedded scripting language interpreter
- php7.2: HTML-embedded scripting language interpreter

Details:

It was discovered that PHP incorrectly handled certain invalid Blowfish
password hashes. An invalid password hash could possibly allow applications
to accept any password as valid, contrary to expectations. (CVE-2023-0567)

It was discovered that PHP incorrectly handled resolving long paths. A
remote attacker could possibly use this issue to obtain or modify sensitive
information. (CVE-2023-0568)

It was discovered that PHP incorrectly handled a large number of parts in
HTTP form uploads. A remote attacker could possibly use this issue to cause
PHP to consume resources, leading to a denial of service. (CVE-2023-0662)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 22.10:
libapache2-mod-php8.1 8.1.7-1ubuntu3.3
php8.1 8.1.7-1ubuntu3.3
php8.1-cgi 8.1.7-1ubuntu3.3
php8.1-cli 8.1.7-1ubuntu3.3
php8.1-fpm 8.1.7-1ubuntu3.3

Ubuntu 22.04 LTS:
libapache2-mod-php8.1 8.1.2-1ubuntu2.11
php8.1 8.1.2-1ubuntu2.11
php8.1-cgi 8.1.2-1ubuntu2.11
php8.1-cli 8.1.2-1ubuntu2.11
php8.1-fpm 8.1.2-1ubuntu2.11

Ubuntu 20.04 LTS:
libapache2-mod-php7.4 7.4.3-4ubuntu2.18
php7.4 7.4.3-4ubuntu2.18
php7.4-cgi 7.4.3-4ubuntu2.18
php7.4-cli 7.4.3-4ubuntu2.18
php7.4-fpm 7.4.3-4ubuntu2.18

Ubuntu 18.04 LTS:
libapache2-mod-php7.2 7.2.24-0ubuntu0.18.04.17
php7.2 7.2.24-0ubuntu0.18.04.17
php7.2-cgi 7.2.24-0ubuntu0.18.04.17
php7.2-cli 7.2.24-0ubuntu0.18.04.17
php7.2-fpm 7.2.24-0ubuntu0.18.04.17

In general, a standard system update will make all the necessary changes.

References:
https://ubuntu.com/security/notices/USN-5902-1
CVE-2023-0567, CVE-2023-0568, CVE-2023-0662

Package Information:
https://launchpad.net/ubuntu/+source/php8.1/8.1.7-1ubuntu3.3
https://launchpad.net/ubuntu/+source/php8.1/8.1.2-1ubuntu2.11
https://launchpad.net/ubuntu/+source/php7.4/7.4.3-4ubuntu2.18
https://launchpad.net/ubuntu/+source/php7.2/7.2.24-0ubuntu0.18.04.17