Ubuntu 6283 Published by

A NSS security update has been released for Ubuntu Linux 14.04 ESM and 16.04 ESM.



USN-5892-2: NSS vulnerability


=========================================================================
Ubuntu Security Notice USN-5892-2
March 06, 2023

nss vulnerability
=========================================================================
A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 16.04 ESM
- Ubuntu 14.04 ESM

Summary:

NSS could be made to crash if it received a specially crafted certificate.

Software Description:
- nss: Network Security Service library

Details:

USN-5892-1 fixed a vulnerability in NSS. This update provides
the corresponding update for Ubuntu 14.04 ESM and Ubuntu 16.04 ESM.

Original advisory details:

Christian Holler discovered that NSS incorrectly handled certain PKCS 12
certificated bundles. A remote attacker could use this issue to cause NSS
to crash, leading to a denial of service, or possibly execute arbitrary
code. (CVE-2023-0767)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 16.04 ESM:
libnss3 2:3.28.4-0ubuntu0.16.04.14+esm4

Ubuntu 14.04 ESM:
libnss3 2:3.28.4-0ubuntu0.14.04.5+esm12

After a standard system update you need to restart any applications that
use NSS to make all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-5892-2
  https://ubuntu.com/security/notices/USN-5892-1
CVE-2023-0767