Ubuntu 6287 Published by

An Open vSwitch security update has been released for Ubuntu Linux 18.04 LTS, 20.04 LTS, 22.04 LTS, and 22.10.



USN-5890-1: Open vSwitch vulnerabilities


==========================================================================
Ubuntu Security Notice USN-5890-1
February 27, 2023

openvswitch vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 22.10
- Ubuntu 22.04 LTS
- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS

Summary:

Several security issues were fixed in Open vSwitch.

Software Description:
- openvswitch: Ethernet virtual switch

Details:

Qian Chen discovered that Open vSwitch incorrectly handled certain
Organization Specific TLVs. A remote attacker could use this issue to cause
Open vSwitch to crash, resulting in a denial of service, or possibly
execute arbitrary code.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 22.10:
openvswitch-common 3.0.3-0ubuntu0.22.10.2

Ubuntu 22.04 LTS:
openvswitch-common 2.17.3-0ubuntu0.22.04.2

Ubuntu 20.04 LTS:
openvswitch-common 2.13.8-0ubuntu1.1

Ubuntu 18.04 LTS:
openvswitch-common 2.9.8-0ubuntu0.18.04.4

In general, a standard system update will make all the necessary changes.

References:
https://ubuntu.com/security/notices/USN-5890-1
CVE-2022-4337, CVE-2022-4338

Package Information:
https://launchpad.net/ubuntu/+source/openvswitch/3.0.3-0ubuntu0.22.10.2
https://launchpad.net/ubuntu/+source/openvswitch/2.17.3-0ubuntu0.22.04.2
https://launchpad.net/ubuntu/+source/openvswitch/2.13.8-0ubuntu1.1
https://launchpad.net/ubuntu/+source/openvswitch/2.9.8-0ubuntu0.18.04.4