Ubuntu 6406 Published by

A NSS security update has been released for Ubuntu Linux 14.04 ESM and 16.04 ESM.



==========================================================================
Ubuntu Security Notice USN-5872-1
February 15, 2023

nss vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 16.04 ESM
- Ubuntu 14.04 ESM

Summary:

Several security issues were fixed in NSS.

Software Description:
- nss: Network Security Service library

Details:

Tavis Ormandy discovered that NSS incorrectly handled an empty pkcs7
sequence. A remote attacker could possibly use this issue to cause NSS to
crash, resulting in a denial of service. (CVE-2022-22747)

Ronald Crane discovered that NSS incorrectly handled certain memory
operations. A remote attacker could use this issue to cause NSS to crash,
resulting in a denial of service, or possibly execute arbitrary code.
(CVE-2022-34480)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 16.04 ESM:
libnss3 2:3.28.4-0ubuntu0.16.04.14+esm3

Ubuntu 14.04 ESM:
libnss3 2:3.28.4-0ubuntu0.14.04.5+esm11

After a standard system update you need to restart any applications that
use NSS to make all the necessary changes.

References:
https://ubuntu.com/security/notices/USN-5872-1
CVE-2022-22747, CVE-2022-34480