Ubuntu 6287 Published by

A Nova security update has been released for Ubuntu Linux 16.04 ESM, 18.04 LTS, and 20.04 LTS.



USN-5866-1: Nova vulnerabilities


=========================================================================
Ubuntu Security Notice USN-5866-1
February 13, 2023

nova vulnerabilities
=========================================================================
A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS
- Ubuntu 16.04 ESM

Summary:

Several security issues were fixed in Nova.

Software Description:
- nova: OpenStack Compute cloud infrastructure

Details:

It was discovered that Nova did not properly manage data logged into the
log file. An attacker with read access to the service's logs could exploit
this issue and may obtain sensitive information. This issue only affected
Ubuntu 16.04 ESM and Ubuntu 18.04 LTS. (CVE-2015-9543)

It was discovered that Nova did not properly handle attaching and
reattaching the encrypted volume. An attacker could possibly use this issue
to perform a denial of service attack. This issue only affected Ubuntu
16.04 ESM. (CVE-2017-18191)

It was discovered that Nova did not properly handle the updation of domain
XML after live migration. An attacker could possibly use this issue to
corrupt the volume or perform a denial of service attack. This issue only
affected Ubuntu 18.04 LTS. (CVE-2020-17376)

It was discovered that Nova was not properly validating the URL passed to
noVNC. An attacker could possibly use this issue by providing malicious URL
to the noVNC proxy to redirect to any desired URL. This issue only affected
Ubuntu 16.04 ESM and Ubuntu 18.04 LTS. (CVE-2021-3654)

It was discovered that Nova did not properly handle changes in the neutron
port of vnic_type type. An authenticated user could possibly use this issue
to perform a denial of service attack. This issue only affected Ubuntu
20.04 LTS. (CVE-2022-37394)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 20.04 LTS:
nova-common 2:21.2.4-0ubuntu2.2
python3-nova 2:21.2.4-0ubuntu2.2

Ubuntu 18.04 LTS:
nova-common 2:17.0.13-0ubuntu5.3
python-nova 2:17.0.13-0ubuntu5.3

Ubuntu 16.04 ESM:
nova-common 2:13.1.4-0ubuntu4.5+esm1
python-nova 2:13.1.4-0ubuntu4.5+esm1

In general, a standard system update will make all the necessary changes.

References:
  https://ubuntu.com/security/notices/USN-5866-1
CVE-2015-9543, CVE-2017-18191, CVE-2020-17376, CVE-2021-3654,
CVE-2022-37394

Package Information:
  https://launchpad.net/ubuntu/+source/nova/2:21.2.4-0ubuntu2.2
  https://launchpad.net/ubuntu/+source/nova/2:17.0.13-0ubuntu5.3