Ubuntu 6415 Published by

A Go security update has been released for Ubuntu Linux 18.04 LTS, 20.04 LTS, 22.04 LTS, and 22.10.



==========================================================================
Ubuntu Security Notice USN-5725-1
November 15, 2022

golang-1.13 vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 22.10
- Ubuntu 22.04 LTS
- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS

Summary:

Go applications could be made to hang or crash if they received
specially crafted input.

Software Description:
- golang-1.13: Go programming language compiler

Details:

Diederik Loerakker, Jonny Rhea, Raúl Kripalani, and Preston
Van Loon discovered that Go incorrectly handled certain inputs.
An attacker could possibly use this issue to cause Go applications
to hang or crash, resulting in a denial of service.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 22.10:
golang-1.13 1.13.8-1ubuntu2.22.10.1
golang-1.13-go 1.13.8-1ubuntu2.22.10.1
golang-1.13-src 1.13.8-1ubuntu2.22.10.1

Ubuntu 22.04 LTS:
golang-1.13 1.13.8-1ubuntu2.22.04.1
golang-1.13-go 1.13.8-1ubuntu2.22.04.1
golang-1.13-src 1.13.8-1ubuntu2.22.04.1

Ubuntu 20.04 LTS:
golang-1.13 1.13.8-1ubuntu1.1
golang-1.13-go 1.13.8-1ubuntu1.1
golang-1.13-src 1.13.8-1ubuntu1.1

Ubuntu 18.04 LTS:
golang-1.13 1.13.8-1ubuntu1~18.04.4
golang-1.13-go 1.13.8-1ubuntu1~18.04.4
golang-1.13-src 1.13.8-1ubuntu1~18.04.4

In general, a standard system update will make all the necessary changes.
You still need to update all packages built with the affected version.

References:
https://ubuntu.com/security/notices/USN-5725-1
CVE-2020-16845

Package Information:
https://launchpad.net/ubuntu/+source/golang-1.13/1.13.8-1ubuntu2.22.10.1
https://launchpad.net/ubuntu/+source/golang-1.13/1.13.8-1ubuntu2.22.04.1
https://launchpad.net/ubuntu/+source/golang-1.13/1.13.8-1ubuntu1.1
https://launchpad.net/ubuntu/+source/golang-1.13/1.13.8-1ubuntu1~18.04.4