SUSE 5001 Published by

A conmon security update has been released for openSUSE Leap 15.5 and SUSE Linux Enterprise 15 SP5.



SUSE-SU-2023:2988-1: important: Security update for conmon


# Security update for conmon

Announcement ID: SUSE-SU-2023:2988-1
Rating: important
References:

* #1208737
* #1209307

Affected Products:

* Containers Module 15-SP5
* openSUSE Leap 15.5
* SUSE Linux Enterprise High Performance Computing 15 SP5
* SUSE Linux Enterprise Real Time 15 SP5
* SUSE Linux Enterprise Server 15 SP5
* SUSE Linux Enterprise Server for SAP Applications 15 SP5

An update that has two fixes can now be installed.

## Description:

This update for conmon fixes the following issues:

conmon was updated to version 2.1.7:

* Bumped go version to 1.19 (bsc#1209307).

Bugfixes:

* Fixed leaking symbolic links in the opt_socket_path directory
* Fixed oom handling issues (bsc#1208737).
* Fixed OOM watcher for cgroupv2 `oom_kill` events

## Patch Instructions:

To install this SUSE Important update use the SUSE recommended installation
methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

* openSUSE Leap 15.5
zypper in -t patch SUSE-2023-2988=1 openSUSE-SLE-15.5-2023-2988=1

* Containers Module 15-SP5
zypper in -t patch SUSE-SLE-Module-Containers-15-SP5-2023-2988=1

## Package List:

* openSUSE Leap 15.5 (aarch64 ppc64le s390x x86_64 i586)
* conmon-debuginfo-2.1.7-150500.9.3.1
* conmon-2.1.7-150500.9.3.1
* Containers Module 15-SP5 (aarch64 ppc64le s390x x86_64)
* conmon-debuginfo-2.1.7-150500.9.3.1
* conmon-2.1.7-150500.9.3.1

## References:

* https://bugzilla.suse.com/show_bug.cgi?id=1208737
* https://bugzilla.suse.com/show_bug.cgi?id=1209307