Red Hat 8831 Published by

A rh-postgresql12-postgresql security update has been released for Red Hat Enterprise Linux 7.



[RHSA-2023:4313-01] Moderate: rh-postgresql12-postgresql security update


=====================================================================
Red Hat Security Advisory

Synopsis: Moderate: rh-postgresql12-postgresql security update
Advisory ID: RHSA-2023:4313-01
Product: Red Hat Software Collections
Advisory URL: https://access.redhat.com/errata/RHSA-2023:4313
Issue date: 2023-07-27
CVE Names: CVE-2023-2454 CVE-2023-2455
=====================================================================

1. Summary:

An update for rh-postgresql12-postgresql is now available for Red Hat
Software Collections.

Red Hat Product Security has rated this update as having a security impact
of Moderate. A Common Vulnerability Scoring System (CVSS) base score, which
gives a detailed severity rating, is available for each vulnerability from
the CVE link(s) in the References section.

2. Relevant releases/architectures:

Red Hat Software Collections for RHEL Workstation(v. 7) - ppc64le, s390x, x86_64
Red Hat Software Collections for RHEL(v. 7) - x86_64

3. Description:

PostgreSQL is an advanced object-relational database management system
(DBMS).

Security Fix(es):

* postgresql: schema_element defeats protective search_path changes
(CVE-2023-2454)

* postgresql: row security policies disregard user ID changes after
inlining. (CVE-2023-2455)

For more details about the security issue(s), including the impact, a CVSS
score, acknowledgments, and other related information, refer to the CVE
page(s) listed in the References section.

4. Solution:

For details on how to apply this update, which includes the changes
described in this advisory, refer to:

https://access.redhat.com/articles/11258

If the postgresql service is running, it will be automatically restarted
after installing this update.

5. Bugs fixed ( https://bugzilla.redhat.com/):

2207568 - CVE-2023-2454 postgresql: schema_element defeats protective search_path changes
2207569 - CVE-2023-2455 postgresql: row security policies disregard user ID changes after inlining.

6. Package List:

Red Hat Software Collections for RHEL Workstation(v. 7):

Source:
rh-postgresql12-postgresql-12.15-1.el7.src.rpm

ppc64le:
rh-postgresql12-postgresql-12.15-1.el7.ppc64le.rpm
rh-postgresql12-postgresql-contrib-12.15-1.el7.ppc64le.rpm
rh-postgresql12-postgresql-contrib-syspaths-12.15-1.el7.ppc64le.rpm
rh-postgresql12-postgresql-debuginfo-12.15-1.el7.ppc64le.rpm
rh-postgresql12-postgresql-devel-12.15-1.el7.ppc64le.rpm
rh-postgresql12-postgresql-docs-12.15-1.el7.ppc64le.rpm
rh-postgresql12-postgresql-libs-12.15-1.el7.ppc64le.rpm
rh-postgresql12-postgresql-plperl-12.15-1.el7.ppc64le.rpm
rh-postgresql12-postgresql-plpython-12.15-1.el7.ppc64le.rpm
rh-postgresql12-postgresql-pltcl-12.15-1.el7.ppc64le.rpm
rh-postgresql12-postgresql-server-12.15-1.el7.ppc64le.rpm
rh-postgresql12-postgresql-server-syspaths-12.15-1.el7.ppc64le.rpm
rh-postgresql12-postgresql-static-12.15-1.el7.ppc64le.rpm
rh-postgresql12-postgresql-syspaths-12.15-1.el7.ppc64le.rpm
rh-postgresql12-postgresql-test-12.15-1.el7.ppc64le.rpm

s390x:
rh-postgresql12-postgresql-12.15-1.el7.s390x.rpm
rh-postgresql12-postgresql-contrib-12.15-1.el7.s390x.rpm
rh-postgresql12-postgresql-contrib-syspaths-12.15-1.el7.s390x.rpm
rh-postgresql12-postgresql-debuginfo-12.15-1.el7.s390x.rpm
rh-postgresql12-postgresql-devel-12.15-1.el7.s390x.rpm
rh-postgresql12-postgresql-docs-12.15-1.el7.s390x.rpm
rh-postgresql12-postgresql-libs-12.15-1.el7.s390x.rpm
rh-postgresql12-postgresql-plperl-12.15-1.el7.s390x.rpm
rh-postgresql12-postgresql-plpython-12.15-1.el7.s390x.rpm
rh-postgresql12-postgresql-pltcl-12.15-1.el7.s390x.rpm
rh-postgresql12-postgresql-server-12.15-1.el7.s390x.rpm
rh-postgresql12-postgresql-server-syspaths-12.15-1.el7.s390x.rpm
rh-postgresql12-postgresql-static-12.15-1.el7.s390x.rpm
rh-postgresql12-postgresql-syspaths-12.15-1.el7.s390x.rpm
rh-postgresql12-postgresql-test-12.15-1.el7.s390x.rpm

x86_64:
rh-postgresql12-postgresql-12.15-1.el7.x86_64.rpm
rh-postgresql12-postgresql-contrib-12.15-1.el7.x86_64.rpm
rh-postgresql12-postgresql-contrib-syspaths-12.15-1.el7.x86_64.rpm
rh-postgresql12-postgresql-debuginfo-12.15-1.el7.x86_64.rpm
rh-postgresql12-postgresql-devel-12.15-1.el7.x86_64.rpm
rh-postgresql12-postgresql-docs-12.15-1.el7.x86_64.rpm
rh-postgresql12-postgresql-libs-12.15-1.el7.x86_64.rpm
rh-postgresql12-postgresql-plperl-12.15-1.el7.x86_64.rpm
rh-postgresql12-postgresql-plpython-12.15-1.el7.x86_64.rpm
rh-postgresql12-postgresql-pltcl-12.15-1.el7.x86_64.rpm
rh-postgresql12-postgresql-server-12.15-1.el7.x86_64.rpm
rh-postgresql12-postgresql-server-syspaths-12.15-1.el7.x86_64.rpm
rh-postgresql12-postgresql-static-12.15-1.el7.x86_64.rpm
rh-postgresql12-postgresql-syspaths-12.15-1.el7.x86_64.rpm
rh-postgresql12-postgresql-test-12.15-1.el7.x86_64.rpm

Red Hat Software Collections for RHEL(v. 7):

Source:
rh-postgresql12-postgresql-12.15-1.el7.src.rpm

x86_64:
rh-postgresql12-postgresql-12.15-1.el7.x86_64.rpm
rh-postgresql12-postgresql-contrib-12.15-1.el7.x86_64.rpm
rh-postgresql12-postgresql-contrib-syspaths-12.15-1.el7.x86_64.rpm
rh-postgresql12-postgresql-debuginfo-12.15-1.el7.x86_64.rpm
rh-postgresql12-postgresql-devel-12.15-1.el7.x86_64.rpm
rh-postgresql12-postgresql-docs-12.15-1.el7.x86_64.rpm
rh-postgresql12-postgresql-libs-12.15-1.el7.x86_64.rpm
rh-postgresql12-postgresql-plperl-12.15-1.el7.x86_64.rpm
rh-postgresql12-postgresql-plpython-12.15-1.el7.x86_64.rpm
rh-postgresql12-postgresql-pltcl-12.15-1.el7.x86_64.rpm
rh-postgresql12-postgresql-server-12.15-1.el7.x86_64.rpm
rh-postgresql12-postgresql-server-syspaths-12.15-1.el7.x86_64.rpm
rh-postgresql12-postgresql-static-12.15-1.el7.x86_64.rpm
rh-postgresql12-postgresql-syspaths-12.15-1.el7.x86_64.rpm
rh-postgresql12-postgresql-test-12.15-1.el7.x86_64.rpm

These packages are GPG signed by Red Hat for security. Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/

7. References:

https://access.redhat.com/security/cve/CVE-2023-2454
https://access.redhat.com/security/cve/CVE-2023-2455
https://access.redhat.com/security/updates/classification/#moderate

8. Contact:

The Red Hat security contact is [secalert@redhat.com]. More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2023 Red Hat, Inc.

--