SUSE 5000 Published by

A redis security update has been released for openSUSE Leap 15.4/15.5 and SUSE Linux Enterprise 15 SP4/5.



SUSE-SU-2023:2924-1: important: Security update for redis


# Security update for redis

Announcement ID: SUSE-SU-2023:2924-1
Rating: important
References:

* #1213193

Cross-References:

* CVE-2022-24834

CVSS scores:

* CVE-2022-24834 ( SUSE ): 7.0 CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
* CVE-2022-24834 ( NVD ): 7.0 CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Affected Products:

* openSUSE Leap 15.4
* openSUSE Leap 15.5
* Server Applications Module 15-SP4
* Server Applications Module 15-SP5
* SUSE Linux Enterprise High Performance Computing 15 SP4
* SUSE Linux Enterprise High Performance Computing 15 SP5
* SUSE Linux Enterprise Real Time 15 SP4
* SUSE Linux Enterprise Real Time 15 SP5
* SUSE Linux Enterprise Server 15 SP4
* SUSE Linux Enterprise Server 15 SP5
* SUSE Linux Enterprise Server for SAP Applications 15 SP4
* SUSE Linux Enterprise Server for SAP Applications 15 SP5
* SUSE Manager Proxy 4.3
* SUSE Manager Retail Branch Server 4.3
* SUSE Manager Server 4.3

An update that solves one vulnerability can now be installed.

## Description:

This update for redis fixes the following issues:

* CVE-2022-24834: Fixed heap overflow in the cjson and cmsgpack libraries
(bsc#1213193).

## Patch Instructions:

To install this SUSE Important update use the SUSE recommended installation
methods like YaST online_update or "zypper patch".
Alternatively you can run the command listed for your product:

* openSUSE Leap 15.4
zypper in -t patch openSUSE-SLE-15.4-2023-2924=1

* openSUSE Leap 15.5
zypper in -t patch openSUSE-SLE-15.5-2023-2924=1

* Server Applications Module 15-SP4
zypper in -t patch SUSE-SLE-Module-Server-Applications-15-SP4-2023-2924=1

* Server Applications Module 15-SP5
zypper in -t patch SUSE-SLE-Module-Server-Applications-15-SP5-2023-2924=1

## Package List:

* openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64)
* redis-debuginfo-6.2.6-150400.3.22.1
* redis-debugsource-6.2.6-150400.3.22.1
* redis-6.2.6-150400.3.22.1
* openSUSE Leap 15.5 (aarch64 ppc64le s390x x86_64)
* redis-debuginfo-6.2.6-150400.3.22.1
* redis-debugsource-6.2.6-150400.3.22.1
* redis-6.2.6-150400.3.22.1
* Server Applications Module 15-SP4 (aarch64 ppc64le s390x x86_64)
* redis-debuginfo-6.2.6-150400.3.22.1
* redis-debugsource-6.2.6-150400.3.22.1
* redis-6.2.6-150400.3.22.1
* Server Applications Module 15-SP5 (aarch64 ppc64le s390x x86_64)
* redis-debuginfo-6.2.6-150400.3.22.1
* redis-debugsource-6.2.6-150400.3.22.1
* redis-6.2.6-150400.3.22.1

## References:

* https://www.suse.com/security/cve/CVE-2022-24834.html
* https://bugzilla.suse.com/show_bug.cgi?id=1213193