SUSE 5058 Published by

A rubygem-actionpack-5_1, rubygem-activesupport-5_1 security update has been released for SUSE Linux Enterprise and openSUSE Leap 15.3/15.4.



SUSE-SU-2022:2108-1: important: Security update for rubygem-actionpack-5_1, rubygem-activesupport-5_1


SUSE Security Update: Security update for rubygem-actionpack-5_1, rubygem-activesupport-5_1
______________________________________________________________________________

Announcement ID: SUSE-SU-2022:2108-1
Rating: important
References: #1185780 #1196182
Cross-References: CVE-2021-22904 CVE-2022-23633
CVSS scores:
CVE-2021-22904 (NVD) : 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVE-2021-22904 (SUSE): 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVE-2022-23633 (NVD) : 5.9 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
CVE-2022-23633 (SUSE): 5.9 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

Affected Products:
SUSE Linux Enterprise High Availability 15 SUSE Linux Enterprise High Availability 15-SP1 SUSE Linux Enterprise High Availability 15-SP2 SUSE Linux Enterprise High Availability 15-SP3 SUSE Linux Enterprise High Availability 15-SP4 SUSE Linux Enterprise High Performance Computing 15 SUSE Linux Enterprise High Performance Computing 15-SP1 SUSE Linux Enterprise High Performance Computing 15-SP2 SUSE Linux Enterprise High Performance Computing 15-SP3 SUSE Linux Enterprise High Performance Computing 15-SP4 SUSE Linux Enterprise Server 15
SUSE Linux Enterprise Server 15-SP1
SUSE Linux Enterprise Server 15-SP2
SUSE Linux Enterprise Server 15-SP3
SUSE Linux Enterprise Server 15-SP4
SUSE Linux Enterprise Server for SAP Applications 15 SUSE Linux Enterprise Server for SAP Applications 15-SP1SUSE Linux Enterprise Server for SAP Applications 15-SP2SUSE Linux Enterprise Server for SAP Applications 15-SP3SUSE Linux Enterprise Server for SAP Applications 15-SP4SUSE Manager Proxy 4.0
SUSE Manager Proxy 4.1
SUSE Manager Proxy 4.2
SUSE Manager Retail Branch Server 4.0
SUSE Manager Retail Branch Server 4.1
SUSE Manager Retail Branch Server 4.2
SUSE Manager Server 4.0
SUSE Manager Server 4.1
SUSE Manager Server 4.2
openSUSE Leap 15.3
openSUSE Leap 15.4
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.
Description:

This update for rubygem-actionpack-5_1 and rubygem-activesupport-5_1 fixes
the following issues:

- CVE-2021-22904: Fixed possible DoS Vulnerability in Action Controller Token Authentication (bsc#1185780)
- CVE-2022-23633: Fixed possible exposure of information vulnerability inAction Pack (bsc#1196182)

Patch Instructions:

To install this SUSE Security Update use the SUSE recommended installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:
- openSUSE Leap 15.4:

zypper in -t patch openSUSE-SLE-15.4-2022-2108=1

- openSUSE Leap 15.3:

zypper in -t patch openSUSE-SLE-15.3-2022-2108=1

- SUSE Linux Enterprise High Availability 15-SP4:

zypper in -t patch SUSE-SLE-Product-HA-15-SP4-2022-2108=1
- SUSE Linux Enterprise High Availability 15-SP3:

zypper in -t patch SUSE-SLE-Product-HA-15-SP3-2022-2108=1
- SUSE Linux Enterprise High Availability 15-SP2:

zypper in -t patch SUSE-SLE-Product-HA-15-SP2-2022-2108=1
- SUSE Linux Enterprise High Availability 15-SP1:

zypper in -t patch SUSE-SLE-Product-HA-15-SP1-2022-2108=1
- SUSE Linux Enterprise High Availability 15:

zypper in -t patch SUSE-SLE-Product-HA-15-2022-2108=1

Package List:

- openSUSE Leap 15.4 (aarch64 ppc64le s390x x86_64):

ruby2.5-rubygem-actionpack-5_1-5.1.4-150000.3.12.1
ruby2.5-rubygem-actionpack-doc-5_1-5.1.4-150000.3.12.1 ruby2.5-rubygem-activesupport-5_1-5.1.4-150000.3.6.1
ruby2.5-rubygem-activesupport-doc-5_1-5.1.4-150000.3.6.1
- openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64):

ruby2.5-rubygem-actionpack-5_1-5.1.4-150000.3.12.1
ruby2.5-rubygem-actionpack-doc-5_1-5.1.4-150000.3.12.1 ruby2.5-rubygem-activesupport-5_1-5.1.4-150000.3.6.1
ruby2.5-rubygem-activesupport-doc-5_1-5.1.4-150000.3.6.1
- SUSE Linux Enterprise High Availability 15-SP4 (aarch64 ppc64le s390x x86_64):

ruby2.5-rubygem-actionpack-5_1-5.1.4-150000.3.12.1
ruby2.5-rubygem-activesupport-5_1-5.1.4-150000.3.6.1

- SUSE Linux Enterprise High Availability 15-SP3 (aarch64 ppc64le s390x x86_64):

ruby2.5-rubygem-actionpack-5_1-5.1.4-150000.3.12.1
ruby2.5-rubygem-activesupport-5_1-5.1.4-150000.3.6.1

- SUSE Linux Enterprise High Availability 15-SP2 (aarch64 ppc64le s390x x86_64):

ruby2.5-rubygem-actionpack-5_1-5.1.4-150000.3.12.1
ruby2.5-rubygem-activesupport-5_1-5.1.4-150000.3.6.1

- SUSE Linux Enterprise High Availability 15-SP1 (aarch64 ppc64le s390x x86_64):

ruby2.5-rubygem-actionpack-5_1-5.1.4-150000.3.12.1
ruby2.5-rubygem-activesupport-5_1-5.1.4-150000.3.6.1

- SUSE Linux Enterprise High Availability 15 (aarch64 ppc64le s390x x86_64):

ruby2.5-rubygem-actionpack-5_1-5.1.4-150000.3.12.1
ruby2.5-rubygem-activesupport-5_1-5.1.4-150000.3.6.1

References:

  https://www.suse.com/security/cve/CVE-2021-22904.html
  https://www.suse.com/security/cve/CVE-2022-23633.html
  https://bugzilla.suse.com/1185780
  https://bugzilla.suse.com/1196182