Red Hat 8826 Published by

A Red Hat JBoss Core Services Apache HTTP Server 2.4.57 security update has been released.



[RHSA-2023:4628-01] Moderate: Red Hat JBoss Core Services Apache HTTP Server 2.4.57 security update


==================================================================== Red Hat Security Advisory

Synopsis: Moderate: Red Hat JBoss Core Services Apache HTTP Server 2.4.57 security update
Advisory ID: RHSA-2023:4628-01
Product: Red Hat JBoss Core Services
Advisory URL: https://access.redhat.com/errata/RHSA-2023:4628
Issue date: 2023-08-15
CVE Names: CVE-2022-24963 CVE-2022-28331 CVE-2022-36760
CVE-2022-37436 CVE-2022-48279 CVE-2023-24021
CVE-2023-27522 CVE-2023-28319 CVE-2023-28321
CVE-2023-28322 CVE-2023-28484 CVE-2023-29469
====================================================================
1. Summary:

Red Hat JBoss Core Services Apache HTTP Server 2.4.57 is now available.

Red Hat Product Security has rated this update as having a security impact
of Moderate. A Common Vulnerability Scoring System (CVSS) base score, which
gives a detailed severity rating, is available for each vulnerability from
the CVE link(s) in the References section.

2. Description:

Red Hat JBoss Core Services is a set of supplementary software for Red Hat
JBoss middleware products. This software, such as Apache HTTP Server, is
common to multiple JBoss middleware products and packaged under Red Hat
JBoss Core Services, to allow for faster distribution of updates and for a
more consistent update experience.

This release of Red Hat JBoss Core Services Apache HTTP Server 2.4.57
serves as a replacement for Red Hat JBoss Core Services Apache HTTP Server
2.4.51 Service Pack 2, and includes bug fixes and enhancements, which are
documented in the Release Notes document linked to in the References.

Security Fix(es):

* apr-util: integer overflow/wraparound in apr_encode (CVE-2022-24963)

* apr-util: Windows out-of-bounds write in apr_socket_sendv function
(CVE-2022-28331)

* httpd: mod_proxy_ajp: Possible request smuggling (CVE-2022-36760)

* httpd: mod_proxy: HTTP response splitting (CVE-2022-37436)

* mod_security: incorrect parsing of HTTP multipart requests leads to web
application firewall bypass (CVE-2022-48279)

* modsecurity: lacking the complete content in FILES_TMP_CONTENT leads to
web application firewall bypass (CVE-2023-24021)

* httpd: mod_proxy_uwsgi HTTP response splitting (CVE-2023-27522)

* curl: use after free in SSH sha256 fingerprint check (CVE-2023-28319)

* curl: IDN wildcard match may lead to Improper Cerificate Validation
(CVE-2023-28321)

* libxml2: NULL dereference in xmlSchemaFixupComplexType (CVE-2023-28484)

* libxml2: Hashing of empty dict strings isn't deterministic
(CVE-2023-29469)

* curl: more POST-after-PUT confusion (CVE-2023-28322)

For more details about the security issue(s), including the impact, a CVSS
score, acknowledgments, and other related information, refer to the CVE
page(s) listed in the References section.

3. Solution:

For details on how to apply this update, which includes the changes
described in this advisory, refer to:

https://access.redhat.com/articles/11258

4. Bugs fixed ( https://bugzilla.redhat.com/):

2161773 - CVE-2022-37436 httpd: mod_proxy: HTTP response splitting
2161777 - CVE-2022-36760 httpd: mod_proxy_ajp: Possible request smuggling
2163615 - CVE-2023-24021 modsecurity: lacking the complete content in FILES_TMP_CONTENT leads to web application firewall bypass
2163622 - CVE-2022-48279 mod_security: incorrect parsing of HTTP multipart requests leads to web application firewall bypass
2169465 - CVE-2022-24963 apr: integer overflow/wraparound in apr_encode
2172556 - CVE-2022-28331 apr: Windows out-of-bounds write in apr_socket_sendv function
2176211 - CVE-2023-27522 httpd: mod_proxy_uwsgi HTTP response splitting
2185984 - CVE-2023-29469 libxml2: Hashing of empty dict strings isn't deterministic
2185994 - CVE-2023-28484 libxml2: NULL dereference in xmlSchemaFixupComplexType
2196778 - CVE-2023-28319 curl: use after free in SSH sha256 fingerprint check
2196786 - CVE-2023-28321 curl: IDN wildcard match may lead to Improper Cerificate Validation
2196793 - CVE-2023-28322 curl: more POST-after-PUT confusion

5. References:

https://access.redhat.com/security/cve/CVE-2022-24963
https://access.redhat.com/security/cve/CVE-2022-28331
https://access.redhat.com/security/cve/CVE-2022-36760
https://access.redhat.com/security/cve/CVE-2022-37436
https://access.redhat.com/security/cve/CVE-2022-48279
https://access.redhat.com/security/cve/CVE-2023-24021
https://access.redhat.com/security/cve/CVE-2023-27522
https://access.redhat.com/security/cve/CVE-2023-28319
https://access.redhat.com/security/cve/CVE-2023-28321
https://access.redhat.com/security/cve/CVE-2023-28322
https://access.redhat.com/security/cve/CVE-2023-28484
https://access.redhat.com/security/cve/CVE-2023-29469
https://access.redhat.com/security/updates/classification/#moderate

6. Contact:

The Red Hat security contact is [secalert@redhat.com]. More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2023 Red Hat, Inc.

--