Red Hat 8942 Published by

A Red Hat Fuse Online 7.10.2.P1 security update has been released.



RHSA-2022:5030-01: Important: Red Hat Fuse Online 7.10.2.P1 security update



=====================================================================
Red Hat Security Advisory

Synopsis: Important: Red Hat Fuse Online 7.10.2.P1 security update
Advisory ID: RHSA-2022:5030-01
Product: Red Hat JBoss Fuse
Advisory URL:   https://access.redhat.com/errata/RHSA-2022:5030
Issue date: 2022-06-14
CVE Names: CVE-2021-22573 CVE-2022-1650
=====================================================================

1. Summary:

A patch update (from 7.10.1 to 7.10.2.P1) is now available for Red Hat Fuse
Online. The purpose of this text-only errata is to inform you about the
security issues fixed in this release.

Red Hat Product Security has rated this update as having a security impact
of Important. A Common Vulnerability Scoring System (CVSS) base score,
which gives a detailed severity rating, is available for each vulnerability
from the CVE link(s) in the References section.

2. Description:

This release of Red Hat Fuse 7.10.2.P1 serves as a replacement for Red Hat
Fuse 7.10 and includes bug fixes and enhancements, which are documented in
the Release Notes document linked in the References.

Security Fix(es):

* google-oauth-client: Token signature not verified [fuse-7]
(CVE-2021-22573)

* eventsource: Exposure of Sensitive Information [fuse-7] (CVE-2022-1650)

For more details about the security issue(s), including the impact, a CVSS
score, acknowledgments, and other related information, refer to the CVE
page(s) listed in the References section.

3. Solution:

Before applying the update, back up your existing installation, including
all applications, configuration files, databases and database settings, and
so on.

Installation instructions are available from the Fuse 7.10 product
documentation page:
  https://access.redhat.com/documentation/en-us/red_hat_fuse/7.10/

4. Bugs fixed (  https://bugzilla.redhat.com/):

2081879 - CVE-2021-22573 google-oauth-client: Token signature not verified
2085307 - CVE-2022-1650 eventsource: Exposure of Sensitive Information

5. References:

  https://access.redhat.com/security/cve/CVE-2021-22573
  https://access.redhat.com/security/cve/CVE-2022-1650
  https://access.redhat.com/security/updates/classification/#important

6. Contact:

The Red Hat security contact is . More contact
details at   https://access.redhat.com/security/team/contact/

Copyright 2022 Red Hat, Inc.