Debian 10020 Published by

The following updates are available for Debian GNU/Linux:

[DLA 3714-1] keystone security update
[DLA 3713-1] subunit bugfix update
ELA-1031-1 xerces-c security update




[DLA 3714-1] keystone security update


- -------------------------------------------------------------------------
Debian LTS Advisory DLA-3714-1 debian-lts@lists.debian.org
https://www.debian.org/lts/security/ Bastien Roucariès
January 21, 2024 https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package : keystone
Version : 2:14.2.0-0+deb10u2
CVE ID : CVE-2021-3563 CVE-2021-38155
Debian Bug : 992070 989998

Brief introduction

CVE-2021-3563

A flaw was found in openstack-keystone. Only the first 72 characters
of an application secret are verified allowing attackers bypass some
password complexity which administrators may be counting on.
The highest threat from this vulnerability is to data confidentiality
and integrity.

CVE-2021-38155

Keystone allowed information disclosure during account locking
(related to PCI DSS features). By guessing the name of an account
and failing to authenticate multiple times, any unauthenticated actor
could both confirm the account exists and obtain that account's
corresponding UUID, which might be leveraged for other unrelated
attacks. All deployments enabling
security_compliance.lockout_failure_attempts are affected.

For Debian 10 buster, these problems have been fixed in version
2:14.2.0-0+deb10u2.

We recommend that you upgrade your keystone packages.

For the detailed security status of keystone please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/keystone

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS



[DLA 3713-1] subunit bugfix update


- -------------------------------------------------------------------------
Debian LTS Advisory DLA-3713-1 debian-lts@lists.debian.org
https://www.debian.org/lts/security/ Bastien Roucariès
January 21, 2024 https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package : subunit
Version : 1.3.0-1+deb10u1

Subunit, a testing component for a few OpenStack projects, was
affected by a major bug. This bug renders building and testing
security updates of OpenStack components difficult, due to
random crashes during building or testing, particularly
keystone component.

For Debian 10 buster, this problem has been fixed in version
1.3.0-1+deb10u1.

We recommend that you upgrade your subunit packages.

For the detailed security status of subunit please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/subunit

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS



ELA-1031-1 xerces-c security update

Package : xerces-c
Version : 3.1.1-5.1+deb8u6 (jessie), 3.1.4+debian-2+deb9u3 (stretch)

Related CVEs :
CVE-2023-37536

Even Rouault discovered that xerces-c, a validating XML parser library
for C++, was vulnerable to integer overflow via crafted .xsd files,
which can lead to out-of-bounds access.

ELA-1031-1 xerces-c security update