Gentoo 2495 Published by

An IBM Spectrum Protect security update has been released for Gentoo Linux.



GLSA 202209-02 : IBM Spectrum Protect: Multiple Vulnerabilities


- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory GLSA 202209-02
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
  https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: High
Title: IBM Spectrum Protect: Multiple Vulnerabilities
Date: September 07, 2022
Bugs: #788115, #829189, #831509
ID: 202209-02

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======
Multiple vulnerabilities have been discovered in IBM Spectrum Protect,
the worst of which could result in arbitrary code execution.

Background
=========
TSM provides the client and the API for IBM Spectrum Protect (formerly
known as Tivoli Storage Manager), a backup and archival client/server
solution targetting large tape libraries.

Affected packages
================
-------------------------------------------------------------------
Package / Vulnerable / Unaffected
-------------------------------------------------------------------
1 app-backup/tsm < 8.1.13.3 >= 8.1.13.3

Description
==========
Multiple vulnerabilities have been discovered in IBM Spectrum Protect.
Please review the CVE identifiers referenced below for details.

Impact
=====
Please review the referenced CVE identifiers for details.

Workaround
=========
There is no known workaround at this time.

Resolution
=========
All IBM Spectrum Protect users should upgrade to the latest version:

# emerge --sync
# emerge --ask --oneshot --verbose ">=app-backup/tsm-8.1.13.3"

References
=========
[ 1 ] CVE-2021-3711
  https://nvd.nist.gov/vuln/detail/CVE-2021-3711
[ 2 ] CVE-2021-3712
  https://nvd.nist.gov/vuln/detail/CVE-2021-3712
[ 3 ] CVE-2021-4104
  https://nvd.nist.gov/vuln/detail/CVE-2021-4104
[ 4 ] CVE-2021-29672
  https://nvd.nist.gov/vuln/detail/CVE-2021-29672
[ 5 ] CVE-2021-39048
  https://nvd.nist.gov/vuln/detail/CVE-2021-39048

Availability
===========
This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  https://security.gentoo.org/glsa/202209-02

Concerns?
========
Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
  https://bugs.gentoo.org.

License
======
Copyright 2022 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

  https://creativecommons.org/licenses/by-sa/2.5