Fedora Linux 8644 Published by

A webkit2gtk3 security update has been released for Fedora 35.



SECURITY: Fedora 35 Update: webkit2gtk3-2.36.3-1.fc35


--------------------------------------------------------------------------------
Fedora Update Notification
FEDORA-2022-c05acca28d
2022-06-18 01:44:47.919366
--------------------------------------------------------------------------------

Name : webkit2gtk3
Product : Fedora 35
Version : 2.36.3
Release : 1.fc35
URL :   https://www.webkitgtk.org/
Summary : GTK Web content engine library
Description :
WebKitGTK is the port of the portable web rendering engine WebKit to the
GTK platform.

This package contains WebKit2 based WebKitGTK for GTK 3.

--------------------------------------------------------------------------------
Update Information:

Update to 2.36.3: * Support capturing already encoded video streams, which
takes advantage of encoding done in hardware by devices which support this
feature. * Avoid using experimental GStreamer elements for video demuxing. *
Avoid using the legacy GStreamer VA-API decoding plug-ins, which often cause
rendering issues and are not much maintained. Their usage can be re-enabled
setting WEBKIT_GST_ENABLE_LEGACY_VAAPI=1 in the environment. * Fix playback of
YouTube streams which use dynamic ad insertion. * Fix display capture with
Pipewire. * Fix several crashes and rendering issues.
--------------------------------------------------------------------------------
ChangeLog:

* Thu Jun 2 2022 Michael Catanzaro 2.36.3-1
- Update to 3.36.3
* Wed May 18 2022 Michael Catanzaro 2.36.2-1
- Update to 2.36.2
--------------------------------------------------------------------------------
References:

[ 1 ] Bug #2092732 - CVE-2022-26700 webkitgtk: Processing maliciously crafted web content may lead to code execution
  https://bugzilla.redhat.com/show_bug.cgi?id=2092732
[ 2 ] Bug #2092733 - CVE-2022-26709 webkitgtk: Processing maliciously crafted web content may lead to use-after-free issue
  https://bugzilla.redhat.com/show_bug.cgi?id=2092733
[ 3 ] Bug #2092734 - CVE-2022-26716 webkitgtk: Processing maliciously crafted web content may lead to memory corruption
  https://bugzilla.redhat.com/show_bug.cgi?id=2092734
[ 4 ] Bug #2092735 - CVE-2022-26717 webkitgtk: Processing maliciously crafted web content may lead to use after free issue
  https://bugzilla.redhat.com/show_bug.cgi?id=2092735
--------------------------------------------------------------------------------

This update can be installed with the "dnf" update program. Use
su -c 'dnf upgrade --advisory FEDORA-2022-c05acca28d' at the command
line. For more information, refer to the dnf documentation available at
  http://dnf.readthedocs.io/en/latest/command_ref.html#upgrade-command-label

All packages are signed with the Fedora Project GPG key. More details on the
GPG keys used by the Fedora Project can be found at
  https://fedoraproject.org/keys
--------------------------------------------------------------------------------
_______________________________________________