Oracle Linux 6161 Published by

A squid security update has been released for Oracle Linux 7.



ELSA-2023-6805 Critical: Oracle Linux 7 squid security update


Oracle Linux Security Advisory ELSA-2023-6805

http://linux.oracle.com/errata/ELSA-2023-6805.html

The following updated rpms for Oracle Linux 7 have been uploaded to the Unbreakable Linux Network:

x86_64:
squid-3.5.20-17.0.1.el7_9.9.x86_64.rpm
squid-migration-script-3.5.20-17.0.1.el7_9.9.x86_64.rpm
squid-sysvinit-3.5.20-17.0.1.el7_9.9.x86_64.rpm

SRPMS:
http://oss.oracle.com/ol7/SRPMS-updates//squid-3.5.20-17.0.1.el7_9.9.src.rpm

Related CVEs:

CVE-2023-46847

Description of changes:

[7:3.5.20-17.0.1]
- Mutiple CVE fixes for squid [Orabug: 33146289]
- Resolves: CVE-2021-28651 squid: Bug 5104: Memory leak in RFC 2169 response parsing (#778)
- Resolves: CVE-2021-28652 squid: Bug 5106: Broken cache manager URL parsing (#788)
- Resolves: CVE-2021-31806,31807,31808 squid: Handle more Range requests (#790)
- Resolves: CVE-2021-33620 squid: Handle more partial responses (#791)

[7:3.5.20-17.9]
- Resolves: RHEL-14789 - squid: Denial of Service in HTTP Digest Authentication
(CVE-2023-46847)