Oracle Linux 6100 Published by

A samba security update has been released for Oracle Linux 9.



ELSA-2023-6744 Moderate: Oracle Linux 9 samba security update


Oracle Linux Security Advisory ELSA-2023-6744

http://linux.oracle.com/errata/ELSA-2023-6744.html

The following updated rpms for Oracle Linux 9 have been uploaded to the Unbreakable Linux Network:

x86_64:
libnetapi-4.18.6-101.el9_3.i686.rpm
libnetapi-4.18.6-101.el9_3.x86_64.rpm
libsmbclient-4.18.6-101.el9_3.i686.rpm
libsmbclient-4.18.6-101.el9_3.x86_64.rpm
libwbclient-4.18.6-101.el9_3.i686.rpm
libwbclient-4.18.6-101.el9_3.x86_64.rpm
python3-samba-4.18.6-101.el9_3.i686.rpm
python3-samba-4.18.6-101.el9_3.x86_64.rpm
python3-samba-dc-4.18.6-101.el9_3.x86_64.rpm
samba-4.18.6-101.el9_3.x86_64.rpm
samba-client-4.18.6-101.el9_3.x86_64.rpm
samba-client-libs-4.18.6-101.el9_3.i686.rpm
samba-client-libs-4.18.6-101.el9_3.x86_64.rpm
samba-common-4.18.6-101.el9_3.noarch.rpm
samba-common-libs-4.18.6-101.el9_3.i686.rpm
samba-common-libs-4.18.6-101.el9_3.x86_64.rpm
samba-common-tools-4.18.6-101.el9_3.x86_64.rpm
samba-dc-libs-4.18.6-101.el9_3.i686.rpm
samba-dc-libs-4.18.6-101.el9_3.x86_64.rpm
samba-dcerpc-4.18.6-101.el9_3.x86_64.rpm
samba-krb5-printing-4.18.6-101.el9_3.x86_64.rpm
samba-ldb-ldap-modules-4.18.6-101.el9_3.x86_64.rpm
samba-libs-4.18.6-101.el9_3.i686.rpm
samba-libs-4.18.6-101.el9_3.x86_64.rpm
samba-tools-4.18.6-101.el9_3.x86_64.rpm
samba-usershares-4.18.6-101.el9_3.x86_64.rpm
samba-vfs-iouring-4.18.6-101.el9_3.x86_64.rpm
samba-winbind-4.18.6-101.el9_3.x86_64.rpm
samba-winbind-clients-4.18.6-101.el9_3.x86_64.rpm
samba-winbind-krb5-locator-4.18.6-101.el9_3.x86_64.rpm
samba-winbind-modules-4.18.6-101.el9_3.i686.rpm
samba-winbind-modules-4.18.6-101.el9_3.x86_64.rpm
samba-winexe-4.18.6-101.el9_3.x86_64.rpm
libnetapi-devel-4.18.6-101.el9_3.i686.rpm
libnetapi-devel-4.18.6-101.el9_3.x86_64.rpm
libsmbclient-devel-4.18.6-101.el9_3.i686.rpm
libsmbclient-devel-4.18.6-101.el9_3.x86_64.rpm
libwbclient-devel-4.18.6-101.el9_3.i686.rpm
libwbclient-devel-4.18.6-101.el9_3.x86_64.rpm
python3-samba-devel-4.18.6-101.el9_3.i686.rpm
python3-samba-devel-4.18.6-101.el9_3.x86_64.rpm
python3-samba-test-4.18.6-101.el9_3.x86_64.rpm
samba-devel-4.18.6-101.el9_3.i686.rpm
samba-devel-4.18.6-101.el9_3.x86_64.rpm
samba-pidl-4.18.6-101.el9_3.noarch.rpm
samba-test-4.18.6-101.el9_3.x86_64.rpm
samba-test-libs-4.18.6-101.el9_3.x86_64.rpm

aarch64:
libnetapi-4.18.6-101.el9_3.aarch64.rpm
libsmbclient-4.18.6-101.el9_3.aarch64.rpm
libwbclient-4.18.6-101.el9_3.aarch64.rpm
python3-samba-4.18.6-101.el9_3.aarch64.rpm
python3-samba-dc-4.18.6-101.el9_3.aarch64.rpm
samba-4.18.6-101.el9_3.aarch64.rpm
samba-client-4.18.6-101.el9_3.aarch64.rpm
samba-client-libs-4.18.6-101.el9_3.aarch64.rpm
samba-common-4.18.6-101.el9_3.noarch.rpm
samba-common-libs-4.18.6-101.el9_3.aarch64.rpm
samba-common-tools-4.18.6-101.el9_3.aarch64.rpm
samba-dc-libs-4.18.6-101.el9_3.aarch64.rpm
samba-dcerpc-4.18.6-101.el9_3.aarch64.rpm
samba-krb5-printing-4.18.6-101.el9_3.aarch64.rpm
samba-ldb-ldap-modules-4.18.6-101.el9_3.aarch64.rpm
samba-libs-4.18.6-101.el9_3.aarch64.rpm
samba-tools-4.18.6-101.el9_3.aarch64.rpm
samba-usershares-4.18.6-101.el9_3.aarch64.rpm
samba-vfs-iouring-4.18.6-101.el9_3.aarch64.rpm
samba-winbind-4.18.6-101.el9_3.aarch64.rpm
samba-winbind-clients-4.18.6-101.el9_3.aarch64.rpm
samba-winbind-krb5-locator-4.18.6-101.el9_3.aarch64.rpm
samba-winbind-modules-4.18.6-101.el9_3.aarch64.rpm
libnetapi-devel-4.18.6-101.el9_3.aarch64.rpm
libsmbclient-devel-4.18.6-101.el9_3.aarch64.rpm
libwbclient-devel-4.18.6-101.el9_3.aarch64.rpm
python3-samba-devel-4.18.6-101.el9_3.aarch64.rpm
python3-samba-test-4.18.6-101.el9_3.aarch64.rpm
samba-devel-4.18.6-101.el9_3.aarch64.rpm
samba-pidl-4.18.6-101.el9_3.noarch.rpm
samba-test-4.18.6-101.el9_3.aarch64.rpm
samba-test-libs-4.18.6-101.el9_3.aarch64.rpm

SRPMS:
http://oss.oracle.com/ol9/SRPMS-updates//samba-4.18.6-101.el9_3.src.rpm

Related CVEs:

CVE-2023-3961
CVE-2023-4091
CVE-2023-42669

Description of changes:

[4.18.6-101]
- resolves: RHEL-11937
Fix CVE-2023-3961 - smbd must check the pipename
- resolves: RHEL-11937
Fix CVE-2023-4091 - SMB clients can truncate files
- resolves: RHEL-11937
Fix CVE-2023-42669 - Remove rpcecho server