Oracle Linux 6161 Published by

A squid security update has been released for Oracle Linux 9.



ELSA-2023-6266 Critical: Oracle Linux 9 squid security update


Oracle Linux Security Advisory ELSA-2023-6266

http://linux.oracle.com/errata/ELSA-2023-6266.html

The following updated rpms for Oracle Linux 9 have been uploaded to the Unbreakable Linux Network:

x86_64:
squid-5.5-5.el9_2.1.x86_64.rpm

aarch64:
squid-5.5-5.el9_2.1.aarch64.rpm

SRPMS:
http://oss.oracle.com/ol9/SRPMS-updates//squid-5.5-5.el9_2.1.src.rpm

Related CVEs:

CVE-2023-46846
CVE-2023-46847
CVE-2023-46848

Description of changes:

[7:5.5-5.el9_2.1]
- Improve HTTP chunked encoding compliance (CVE-2023-46846)
- Fix stack buffer overflow when parsing Digest Authorization (CVE-2023-46847)
- Fix userinfo percent-encoding (CVE-2023-46848)