Oracle Linux 6139 Published by

A webkit2gtk3 security update has been released for Oracle Linux 8.



El-errata: ELSA-2023-3108 Important: Oracle Linux 8 webkit2gtk3 security update


Oracle Linux Security Advisory ELSA-2023-3108

  http://linux.oracle.com/errata/ELSA-2023-3108.html

The following updated rpms for Oracle Linux 8 have been uploaded to the Unbreakable Linux Network:

x86_64:
webkit2gtk3-2.38.5-1.el8_8.3.i686.rpm
webkit2gtk3-2.38.5-1.el8_8.3.x86_64.rpm
webkit2gtk3-devel-2.38.5-1.el8_8.3.i686.rpm
webkit2gtk3-devel-2.38.5-1.el8_8.3.x86_64.rpm
webkit2gtk3-jsc-2.38.5-1.el8_8.3.i686.rpm
webkit2gtk3-jsc-2.38.5-1.el8_8.3.x86_64.rpm
webkit2gtk3-jsc-devel-2.38.5-1.el8_8.3.i686.rpm
webkit2gtk3-jsc-devel-2.38.5-1.el8_8.3.x86_64.rpm

aarch64:
webkit2gtk3-2.38.5-1.el8_8.3.aarch64.rpm
webkit2gtk3-devel-2.38.5-1.el8_8.3.aarch64.rpm
webkit2gtk3-jsc-2.38.5-1.el8_8.3.aarch64.rpm
webkit2gtk3-jsc-devel-2.38.5-1.el8_8.3.aarch64.rpm

SRPMS:
  http://oss.oracle.com/ol8/SRPMS-updates//webkit2gtk3-2.38.5-1.el8_8.3.src.rpm

Related CVEs:

CVE-2023-2203



Description of changes:

[2.38.5-1.3]
- Restore libwpe and wpebackend-fdo dependencies
Related: #2185741 (sort of)

[2.38.5-1.2]
- Disable libwpe and wpebackend-fdo dependencies
Related: #2185741 (sort of)

[2.38.5-1.1]
- Add patch for CVE-2023-28205
Resolves: #2185741

[2.38.5-1]
- Update to 2.38.5
Related: #2127468

[2.38.4-1]
- Update to 2.38.4
Related: #2127468

[2.38.3-1]
- Update to 2.38.3
Related: #2127468

[2.38.2-1]
- Update to 2.38.2
Related: #2127468

[2.38.1-2]
- Fix crashes on aarch64
Enable WPE renderer
Related: #2127468

[2.38.1-1]
- Update to 2.38.1
Related: #2127468

_______________________________________________