Oracle Linux 6138 Published by

A httpd and mod_http2 security update has been released for Oracle Linux 9.



El-errata: ELSA-2023-1670 Important: Oracle Linux 9 httpd and mod_http2 security update


Oracle Linux Security Advisory ELSA-2023-1670

  http://linux.oracle.com/errata/ELSA-2023-1670.html

The following updated rpms for Oracle Linux 9 have been uploaded to the Unbreakable Linux Network:

x86_64:
httpd-2.4.53-7.0.1.el9_1.5.x86_64.rpm
httpd-core-2.4.53-7.0.1.el9_1.5.x86_64.rpm
httpd-devel-2.4.53-7.0.1.el9_1.5.x86_64.rpm
httpd-filesystem-2.4.53-7.0.1.el9_1.5.noarch.rpm
httpd-manual-2.4.53-7.0.1.el9_1.5.noarch.rpm
httpd-tools-2.4.53-7.0.1.el9_1.5.x86_64.rpm
mod_http2-1.15.19-3.el9_1.5.x86_64.rpm
mod_ldap-2.4.53-7.0.1.el9_1.5.x86_64.rpm
mod_lua-2.4.53-7.0.1.el9_1.5.x86_64.rpm
mod_proxy_html-2.4.53-7.0.1.el9_1.5.x86_64.rpm
mod_session-2.4.53-7.0.1.el9_1.5.x86_64.rpm
mod_ssl-2.4.53-7.0.1.el9_1.5.x86_64.rpm

aarch64:
httpd-2.4.53-7.0.1.el9_1.5.aarch64.rpm
httpd-core-2.4.53-7.0.1.el9_1.5.aarch64.rpm
httpd-devel-2.4.53-7.0.1.el9_1.5.aarch64.rpm
httpd-filesystem-2.4.53-7.0.1.el9_1.5.noarch.rpm
httpd-manual-2.4.53-7.0.1.el9_1.5.noarch.rpm
httpd-tools-2.4.53-7.0.1.el9_1.5.aarch64.rpm
mod_http2-1.15.19-3.el9_1.5.aarch64.rpm
mod_ldap-2.4.53-7.0.1.el9_1.5.aarch64.rpm
mod_lua-2.4.53-7.0.1.el9_1.5.aarch64.rpm
mod_proxy_html-2.4.53-7.0.1.el9_1.5.aarch64.rpm
mod_session-2.4.53-7.0.1.el9_1.5.aarch64.rpm
mod_ssl-2.4.53-7.0.1.el9_1.5.aarch64.rpm

SRPMS:
  http://oss.oracle.com/ol9/SRPMS-updates//httpd-2.4.53-7.0.1.el9_1.5.src.rpm
  http://oss.oracle.com/ol9/SRPMS-updates//mod_http2-1.15.19-3.el9_1.5.src.rpm

Related CVEs:

CVE-2023-25690



Description of changes:

httpd
[2.4.53-7.0.1.5]
- Replace index.html with Oracle's index page oracle_index.html.

[2.4.53-7.5]
- Resolves: #2177751 - CVE-2023-25690 httpd: HTTP request splitting with
mod_rewrite and mod_proxy

mod_http2
[1.15.19-3.5]
- Resolves: #2177751 - CVE-2023-25690 httpd: HTTP request splitting with
mod_rewrite and mod_proxy

[1.15.19-3]
- Resolves: #2066311 - CVE-2021-44224 httpd: possible NULL dereference or SSRF
in forward proxy configurations

_______________________________________________