Oracle Linux 6139 Published by

A samba security update has been released for Oracle Linux 8.



El-errata: ELSA-2023-0838 Important: Oracle Linux 8 samba security update


Oracle Linux Security Advisory ELSA-2023-0838

  http://linux.oracle.com/errata/ELSA-2023-0838.html

The following updated rpms for Oracle Linux 8 have been uploaded to the Unbreakable Linux Network:

x86_64:
ctdb-4.16.4-4.0.1.el8_7.x86_64.rpm
libsmbclient-4.16.4-4.0.1.el8_7.i686.rpm
libsmbclient-4.16.4-4.0.1.el8_7.x86_64.rpm
libwbclient-4.16.4-4.0.1.el8_7.i686.rpm
libwbclient-4.16.4-4.0.1.el8_7.x86_64.rpm
python3-samba-4.16.4-4.0.1.el8_7.i686.rpm
python3-samba-4.16.4-4.0.1.el8_7.x86_64.rpm
python3-samba-test-4.16.4-4.0.1.el8_7.x86_64.rpm
samba-4.16.4-4.0.1.el8_7.x86_64.rpm
samba-client-4.16.4-4.0.1.el8_7.x86_64.rpm
samba-client-libs-4.16.4-4.0.1.el8_7.i686.rpm
samba-client-libs-4.16.4-4.0.1.el8_7.x86_64.rpm
samba-common-4.16.4-4.0.1.el8_7.noarch.rpm
samba-common-libs-4.16.4-4.0.1.el8_7.i686.rpm
samba-common-libs-4.16.4-4.0.1.el8_7.x86_64.rpm
samba-common-tools-4.16.4-4.0.1.el8_7.x86_64.rpm
samba-krb5-printing-4.16.4-4.0.1.el8_7.x86_64.rpm
samba-libs-4.16.4-4.0.1.el8_7.i686.rpm
samba-libs-4.16.4-4.0.1.el8_7.x86_64.rpm
samba-pidl-4.16.4-4.0.1.el8_7.noarch.rpm
samba-test-4.16.4-4.0.1.el8_7.x86_64.rpm
samba-test-libs-4.16.4-4.0.1.el8_7.x86_64.rpm
samba-vfs-iouring-4.16.4-4.0.1.el8_7.x86_64.rpm
samba-winbind-4.16.4-4.0.1.el8_7.x86_64.rpm
samba-winbind-clients-4.16.4-4.0.1.el8_7.x86_64.rpm
samba-winbind-krb5-locator-4.16.4-4.0.1.el8_7.x86_64.rpm
samba-winbind-modules-4.16.4-4.0.1.el8_7.i686.rpm
samba-winbind-modules-4.16.4-4.0.1.el8_7.x86_64.rpm
samba-winexe-4.16.4-4.0.1.el8_7.x86_64.rpm
libsmbclient-devel-4.16.4-4.0.1.el8_7.i686.rpm
libsmbclient-devel-4.16.4-4.0.1.el8_7.x86_64.rpm
libwbclient-devel-4.16.4-4.0.1.el8_7.i686.rpm
libwbclient-devel-4.16.4-4.0.1.el8_7.x86_64.rpm
samba-devel-4.16.4-4.0.1.el8_7.i686.rpm
samba-devel-4.16.4-4.0.1.el8_7.x86_64.rpm
samba-vfs-glusterfs-4.16.4-4.0.1.el8_7.x86_64.rpm

aarch64:
ctdb-4.16.4-4.0.1.el8_7.aarch64.rpm
libsmbclient-4.16.4-4.0.1.el8_7.aarch64.rpm
libwbclient-4.16.4-4.0.1.el8_7.aarch64.rpm
python3-samba-4.16.4-4.0.1.el8_7.aarch64.rpm
python3-samba-test-4.16.4-4.0.1.el8_7.aarch64.rpm
samba-4.16.4-4.0.1.el8_7.aarch64.rpm
samba-client-4.16.4-4.0.1.el8_7.aarch64.rpm
samba-client-libs-4.16.4-4.0.1.el8_7.aarch64.rpm
samba-common-4.16.4-4.0.1.el8_7.noarch.rpm
samba-common-libs-4.16.4-4.0.1.el8_7.aarch64.rpm
samba-common-tools-4.16.4-4.0.1.el8_7.aarch64.rpm
samba-krb5-printing-4.16.4-4.0.1.el8_7.aarch64.rpm
samba-libs-4.16.4-4.0.1.el8_7.aarch64.rpm
samba-pidl-4.16.4-4.0.1.el8_7.noarch.rpm
samba-test-4.16.4-4.0.1.el8_7.aarch64.rpm
samba-test-libs-4.16.4-4.0.1.el8_7.aarch64.rpm
samba-vfs-iouring-4.16.4-4.0.1.el8_7.aarch64.rpm
samba-winbind-4.16.4-4.0.1.el8_7.aarch64.rpm
samba-winbind-clients-4.16.4-4.0.1.el8_7.aarch64.rpm
samba-winbind-krb5-locator-4.16.4-4.0.1.el8_7.aarch64.rpm
samba-winbind-modules-4.16.4-4.0.1.el8_7.aarch64.rpm
libsmbclient-devel-4.16.4-4.0.1.el8_7.aarch64.rpm
libwbclient-devel-4.16.4-4.0.1.el8_7.aarch64.rpm
samba-devel-4.16.4-4.0.1.el8_7.aarch64.rpm
samba-vfs-glusterfs-4.16.4-4.0.1.el8_7.aarch64.rpm

SRPMS:
  http://oss.oracle.com/ol8/SRPMS-updates//samba-4.16.4-4.0.1.el8_7.src.rpm

Related CVEs:

CVE-2022-38023



Description of changes:

[4.16.4-4.0.1]
- Gluster volumes not accessible via Samba due to missing samba-vfs-glusterfs
in OL8 [Orabug: 30205755]

[4.16.4-4]
- related: rhbz#2154369 - Add additional patch for CVE-2022-38023

[4.16.4-3]
- resolves: rhbz#2154369 - Fix CVE-2022-38023

[4.16.4-2]
- resolves: rhbz#2120956 - Do not require samba package in python3-samba

[4.16.4-1]
- Rebase to version 4.16.4
- resolves: rhbz#2108331 - Fix CVE-2022-32742

[4.16.3-0]
- related: rhbz#2077468 - Rebase Samba to 4.16.3
- resolves: rhbz#2106672 - The pcap background queue process should not be stopped
- resolves: rhbz#2106263 - Fix crash in rpcd_classic
- resolves: rhbz#2100093 - Fix net ads info returns LDAP server and LDAP server name

[4.16.2-1]
- resolves: rhbz#2084162 - Fix printer displays only after 300 seconds timeout

[4.16.2-0]
- Fix rpminspect abidiff
- related: rhbz#2077468 - Rebase Samba to 4.16.2

[4.16.1-0]
- Update to Samba 4.16.1
- resolves: rhbz#2077468 Rebase Samba to the the latest 4.16.x release

_______________________________________________