Debian 10020 Published by

A cups-filters security update has been released for Debian GNU/Linux 10 LTS to address an issue that may result in the execution of arbitrary commands.



DLA 3430-1: cups-filters security update



- ------------------------------------------------------------------------
Debian LTS Advisory DLA-3430-1 debian-lts@lists.debian.org
  https://www.debian.org/lts/security/ Thorsten Alteholz
May 22, 2023   https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package : cups-filters
Version : 1.21.6-5+deb10u1
CVE ID : CVE-2023-24805
Debian Bug : 1036224

It was discovered that missing input sanitising in cups-filters, when
using the Backend Error Handler (beh) backend to create an accessible
network printer, may result in the execution of arbitrary commands.

For Debian 10 buster, this problem has been fixed in version
1.21.6-5+deb10u1.

We recommend that you upgrade your cups-filters packages.

For the detailed security status of cups-filters please refer to
its security tracker page at:
  https://security-tracker.debian.org/tracker/cups-filters

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at:   https://wiki.debian.org/LTS