Debian 9810 Published by

A c-ares security update has been released for Debian GNU/Linux 10 LTS to address missing input string checks.



DLA 3323-1: c-ares security update


-------------------------------------------------------------------------
Debian LTS Advisory DLA-3323-1 debian-lts@lists.debian.org
  https://www.debian.org/lts/security/ Markus Koschany
February 18, 2023   https://wiki.debian.org/LTS
-------------------------------------------------------------------------

Package : c-ares
Version : 1.14.0-1+deb10u2
CVE ID : CVE-2022-4904
Debian Bug : 1031525

It was discovered that in c-ares, an asynchronous name resolver library,
the config_sortlist function is missing checks about the validity of the
input string, which allows a possible arbitrary length stack overflow and
thus may cause a denial of service.

For Debian 10 buster, this problem has been fixed in version
1.14.0-1+deb10u2.

We recommend that you upgrade your c-ares packages.

For the detailed security status of c-ares please refer to
its security tracker page at:
  https://security-tracker.debian.org/tracker/c-ares

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at:   https://wiki.debian.org/LTS