AlmaLinux 2226 Published by

A postgresql security update has been released for AlmaLinux 9.



ALSA-2023:3714 Moderate: postgresql security update


Type:
security

Severity:
moderate

Release date:
2023-06-23

Description
Security Fix(es):
* postgresql: schema_element defeats protective search_path changes (CVE-2023-2454)
* postgresql: row security policies disregard user ID changes after inlining. (CVE-2023-2455)
For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

References:
CVE-2023-2454
CVE-2023-2455
RHSA-2023:3714
ALSA-2023:3714

Updates packages:
postgresql-plpython3-13.11-1.el9_2.ppc64le.rpm
postgresql-test-13.11-1.el9_2.ppc64le.rpm
postgresql-13.11-1.el9_2.ppc64le.rpm
postgresql-server-13.11-1.el9_2.x86_64.rpm
postgresql-static-13.11-1.el9_2.s390x.rpm
postgresql-plperl-13.11-1.el9_2.ppc64le.rpm
postgresql-server-13.11-1.el9_2.s390x.rpm
postgresql-server-devel-13.11-1.el9_2.s390x.rpm
postgresql-private-libs-13.11-1.el9_2.x86_64.rpm
postgresql-static-13.11-1.el9_2.ppc64le.rpm
postgresql-pltcl-13.11-1.el9_2.s390x.rpm
postgresql-server-devel-13.11-1.el9_2.ppc64le.rpm
postgresql-contrib-13.11-1.el9_2.aarch64.rpm
postgresql-docs-13.11-1.el9_2.x86_64.rpm
postgresql-pltcl-13.11-1.el9_2.ppc64le.rpm
postgresql-upgrade-devel-13.11-1.el9_2.ppc64le.rpm
postgresql-plperl-13.11-1.el9_2.x86_64.rpm
postgresql-test-13.11-1.el9_2.x86_64.rpm
postgresql-server-devel-13.11-1.el9_2.x86_64.rpm
postgresql-pltcl-13.11-1.el9_2.aarch64.rpm
postgresql-server-13.11-1.el9_2.aarch64.rpm
postgresql-13.11-1.el9_2.x86_64.rpm
postgresql-upgrade-13.11-1.el9_2.s390x.rpm
postgresql-pltcl-13.11-1.el9_2.x86_64.rpm
postgresql-server-13.11-1.el9_2.ppc64le.rpm
postgresql-plperl-13.11-1.el9_2.aarch64.rpm
postgresql-private-libs-13.11-1.el9_2.s390x.rpm
postgresql-private-libs-13.11-1.el9_2.ppc64le.rpm
postgresql-13.11-1.el9_2.s390x.rpm
postgresql-upgrade-13.11-1.el9_2.aarch64.rpm
postgresql-plperl-13.11-1.el9_2.s390x.rpm
postgresql-docs-13.11-1.el9_2.ppc64le.rpm
postgresql-docs-13.11-1.el9_2.aarch64.rpm
postgresql-private-devel-13.11-1.el9_2.s390x.rpm
postgresql-server-devel-13.11-1.el9_2.aarch64.rpm
postgresql-upgrade-13.11-1.el9_2.ppc64le.rpm
postgresql-contrib-13.11-1.el9_2.x86_64.rpm
postgresql-private-devel-13.11-1.el9_2.x86_64.rpm
postgresql-plpython3-13.11-1.el9_2.s390x.rpm
postgresql-private-libs-13.11-1.el9_2.aarch64.rpm
postgresql-upgrade-devel-13.11-1.el9_2.aarch64.rpm
postgresql-docs-13.11-1.el9_2.s390x.rpm
postgresql-contrib-13.11-1.el9_2.ppc64le.rpm
postgresql-static-13.11-1.el9_2.aarch64.rpm
postgresql-upgrade-13.11-1.el9_2.x86_64.rpm
postgresql-test-13.11-1.el9_2.s390x.rpm
postgresql-13.11-1.el9_2.aarch64.rpm
postgresql-upgrade-devel-13.11-1.el9_2.s390x.rpm
postgresql-upgrade-devel-13.11-1.el9_2.x86_64.rpm
postgresql-test-13.11-1.el9_2.aarch64.rpm
postgresql-private-devel-13.11-1.el9_2.aarch64.rpm
postgresql-static-13.11-1.el9_2.x86_64.rpm
postgresql-plpython3-13.11-1.el9_2.x86_64.rpm
postgresql-private-devel-13.11-1.el9_2.ppc64le.rpm
postgresql-contrib-13.11-1.el9_2.s390x.rpm
postgresql-plpython3-13.11-1.el9_2.aarch64.rpm

Notes:
This page is generated automatically from Red Hat security data and has not been checked for errors. For clarification or corrections please contact the AlmaLinux Packaging Team.

  ALSA-2023:3714 Moderate: postgresql security update