wlanconfig:no such command.......how do i get it??

i have a netgear WG311T wireless PCI card (having atheros chipset). . . . . . i intend to set my machine as an access point using madwifi. . . . i hv followed the foll procedure till now. . . . 1) check the current kernel details in terminal by running uname -a.

Linux Networking 361 This topic was started by ,



data/avatar/default/avatar33.webp

3 Posts
Location -
Joined 2006-02-10
i have a netgear WG311T wireless PCI card (having atheros chipset)......i intend to set my machine as an access point using madwifi ....i hv followed the foll procedure till now....
 
 
 
 
1) check the current kernel details in terminal by running "uname -a". Write down what is shown.
 
2) Go to ATrpm ( http://atrpms.net/dist/fc4/madwifi/) in Firefox 1.07 (or later) and download madwifi-0.9.6.0-18.rhfc4.at.i386.rpm by clicking on the link (I'm not running a 64bit processor). When this is run in the Firefox download manager you get the option to "open with" and in the drop down box "install packages (default)". Hit OK. This will install this rpm. Do this before you proceed to the next step.
 
3) Now search the ATrpm Fedora driver list ( http://atrpms.net/dist/fc4/madwifi/) and make sure you get the correct rpm to match your kernel details you wrote down in Step 1) above. In my case "uname -a" told me that my kernal is 2.6.14-1.1644_FC4. I do not have a 64bit processor running so I selected this rpm: madwifi-kmdl-2.6.14-1.1644_FC4-0.9.6.0-18.rhfc4.at.i686.rpm. Make sure you click on the "madwifi-kmdl-" rpm that matches both your your processor and kernel.
 
4) Click on the correct rpm as described in 3) above and Firefox will offer to install it. Click OK.
 
5) Reboot your computer.
 
6) Go to Desktop in your FC4 top panel. Select "System settings" then "Network". Type in your root password when asked and you will be taken to graphic menu that will list your network cards. In my case my laptop has an ethernet card and the wireless card. Until I installed Madwifi as described above the wireless card was not listed.
 
7) The wireless card is now listed under "Devices", in my case under the ethernet card. Check the box to the left next of the wireless card and press the "Activate" button.
 
8) When you go to leave the network menu you will be asked to save the new settings. Press OK. You're almost there.
 
9) Your card will still not be working. Restart your computer.
 
10) Bingo! It works.
 
 
i hv read wlanconfig requires wlan-ng drivers.....so how do i install them keeping in mind the above config that i have already done.....do i need to undo all that????

Participate on our website and join the conversation

You have already an account on our website? Use the link below to login.
Login
Create a new user account. Registration is free and takes only a few seconds.
Register
This topic is archived. New comments cannot be posted and votes cannot be cast.

Responses to this topic



data/avatar/default/avatar10.webp

2895 Posts
Location -
Joined 2002-08-30
Quote:i hv read wlanconfig requires wlan-ng drivers.....so how do i install them keeping in mind the above config that i have already done.....do i need to undo all that????

You don't need wlan-ng. This is a totally different driver package.

Where did you get these instructions? It looks like you read a previous thread here that had two different methods of getting wireless up?


data/avatar/default/avatar33.webp

3 Posts
Location -
Joined 2006-02-10
OP
thank you for replyin
 
ya i did read the previous threads and hv followed the method using ATrpm.........my card setup was perfect....it got detected.but now i wld like to setup my machine as an access point what should i do for that?????? iwconfig allows to set up parameters for the clients....right??? so is there any other command for access points?????
 
any sort of help would be appreciated.