Debian 9973 Published by

Updated yard packages are available for Debian GNU/Linux 11 and 12 to address a cross-site scripting issue:

[DSA 5635-1] yard security update




[DSA 5635-1] yard security update


- -------------------------------------------------------------------------
Debian Security Advisory DSA-5635-1 security@debian.org
https://www.debian.org/security/ Moritz Muehlenhoff
March 04, 2024 https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : yard
CVE ID : CVE-2024-27285

Aviv Keller discovered that the frames.html file generated by YARD, a
documentation generation tool for the Ruby programming language, was
vulnerable to cross-site scripting.

For the oldstable distribution (bullseye), this problem has been fixed
in version 0.9.24-1+deb11u1.

For the stable distribution (bookworm), this problem has been fixed in
version 0.9.28-2+deb12u2.

We recommend that you upgrade your yard packages.

For the detailed security status of yard please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/yard

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/