Debian 9955 Published by

Updated xorg-server, snip, freeimage, and intel-microcode packages are available for Debian GNU/Linux:

[DSA 5576-2] xorg-server security update
[DLA 3691-1] spip security update
[DSA 5579-1] freeimage security update
[DLA 3686-2] xorg-server security update
ELA-1019-2 xorg-server security update
ELA-1021-1 intel-microcode security update




[DSA 5576-2] xorg-server security update


- -------------------------------------------------------------------------
Debian Security Advisory DSA-5576-2 security@debian.org
https://www.debian.org/security/ Salvatore Bonaccorso
December 17, 2023 https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : xorg-server
CVE ID : CVE-2023-6377

The initial fix for CVE-2023-6377 as applied in DSA 5576-1 did not fully
fix the vulnerability. Updated packages correcting this issue including
the upstream merged commit are now available.

For the oldstable distribution (bullseye), this problem has been fixed
in version 2:1.20.11-1+deb11u10.

For the stable distribution (bookworm), this problem has been fixed in
version 2:21.1.7-3+deb12u4.

We recommend that you upgrade your xorg-server packages.

For the detailed security status of xorg-server please refer to its
security tracker page at:
https://security-tracker.debian.org/tracker/xorg-server

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/


[DLA 3691-1] spip security update


-------------------------------------------------------------------------
Debian LTS Advisory DLA-3691-1 debian-lts@lists.debian.org
https://www.debian.org/lts/security/ Guilhem Moulin
December 18, 2023 https://wiki.debian.org/LTS
-------------------------------------------------------------------------

Package : spip
Version : 3.2.4-1+deb10u12

Multiple security issues were discovered in SPIP, a content management
system, which could lead to denial of service or information disclosure.

For Debian 10 buster, this problem has been fixed in version
3.2.4-1+deb10u12.

We recommend that you upgrade your spip packages.

For the detailed security status of spip please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/spip

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS



[DSA 5579-1] freeimage security update


- -------------------------------------------------------------------------
Debian Security Advisory DSA-5579-1 security@debian.org
https://www.debian.org/security/ Moritz Muehlenhoff
December 17, 2023 https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package : freeimage
CVE ID : CVE-2020-21427 CVE-2020-21428 CVE-2020-22524

Multiple vulnerabilities were discovered in FreeImage, a support library
for graphics image formats, which could result in the execution of
arbitrary code if malformed image files are processed.

For the oldstable distribution (bullseye), these problems have been fixed
in version 3.18.0+ds2-6+deb11u1.

For the stable distribution (bookworm), these problems have been fixed in
version 3.18.0+ds2-9+deb12u1.

We recommend that you upgrade your freeimage packages.

For the detailed security status of freeimage please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/freeimage

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/


[DLA 3686-2] xorg-server security update


- -------------------------------------------------------------------------
Debian LTS Advisory DLA-3686-2 debian-lts@lists.debian.org
https://www.debian.org/lts/security/ Thorsten Alteholz
December 17, 2023 https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package : xorg-server
Version : 2:1.20.4-1+deb10u12
CVE ID : CVE-2023-6377

The initial fix for CVE-2023-6377 as applied in DLA 3686-1 did not fully
fix the vulnerability. Updated packages correcting this issue including
the upstream merged commit are now available.

For Debian 10 buster, this problem has been fixed in version
2:1.20.4-1+deb10u12.

We recommend that you upgrade your xorg-server packages.

For the detailed security status of xorg-server please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/xorg-server

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS



ELA-1019-2 xorg-server security update

Package : xorg-server


Version : 2:1.16.4-1+deb8u14 (jessie), 2:1.19.2-1+deb9u17 (stretch)


Related CVEs :

CVE-2023-6377



The initial fix for CVE-2023-6377 as applied in ELA 1019-1 did not fully
fix the vulnerability. Updated packages correcting this issue including
the upstream merged commit are now available.

ELA-1019-2 xorg-server security update


ELA-1021-1 intel-microcode security update

Package : intel-microcode


Version : 3.20231114.1~deb8u1 (jessie), 3.20231114.1~deb9u1 (stretch)


Related CVEs :

CVE-2023-23583



Benoit Morgan, Paul Grosen, Thais Moreira Hamasaki, Ke Sun, Alyssa
Milburn, Hisham Shafi, Nir Shlomovich, Tavis Ormandy, Daniel Moghimi,
Josh Eads, Salman Qazi, Alexandra Sandulescu, Andy Nguyen, Eduardo Vela,
Doug Kwan, and Kostik Shtoyk discovered that some Intel processors
mishandle repeated sequences of instructions leading to unexpected
behavior, which may result in privilege escalation, information
disclosure or denial of service. This vulnerability is also known as
reptar and has been assigend CVE-2023-23583.

ELA-1021-1 intel-microcode security update