Ubuntu 6416 Published by

A xrdp security update has been released for Ubuntu Linux 14.04 LTS, 16.04 LTS, 18.04 LTS, and 20.04 LTS.



[USN-6469-1] xrdp vulnerability


==========================================================================
Ubuntu Security Notice USN-6469-1
November 02, 2023

xrdp vulnerability
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

- Ubuntu 20.04 LTS
- Ubuntu 18.04 LTS (Available with Ubuntu Pro)
- Ubuntu 16.04 LTS (Available with Ubuntu Pro)
- Ubuntu 14.04 LTS (Available with Ubuntu Pro)

Summary:

xrdp could be made to crash or run programs if it received
specially crafted network traffic.

Software Description:
- xrdp: Remote Desktop Protocol (RDP) server

Details:

Ashley Newson discovered that xrdp incorrectly handled memory when
processing certain incoming connections. An attacker could possibly use
this issue to cause a denial of service or arbitrary code execution.

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 20.04 LTS:
xrdp 0.9.12-1ubuntu0.1

Ubuntu 18.04 LTS (Available with Ubuntu Pro):
xrdp 0.9.5-2ubuntu0.1~esm1

Ubuntu 16.04 LTS (Available with Ubuntu Pro):
xrdp 0.6.1-2ubuntu0.3+esm2

Ubuntu 14.04 LTS (Available with Ubuntu Pro):
xrdp 0.6.0-1ubuntu0.1+esm2

In general, a standard system update will make all the necessary changes.

References:
https://ubuntu.com/security/notices/USN-6469-1
CVE-2020-4044

Package Information:
https://launchpad.net/ubuntu/+source/xrdp/0.9.12-1ubuntu0.1